1 Reply Latest reply on Mar 7, 2016 1:48 AM by thedesmodus

    How do I fix this? Occasional error crashes InDesign and loses/resets prefs to factory default.

    helpd88705810 Level 1

      NOTE: I'm running Mac OS X El Capitan 10.11.3 on a Mac Pro (Mid 2010) and Adobe InDesign CC 2015 (11.2.0.99).

       

      Hello! Occasionally when working in InDesign, when I go to save a document I may receive the following error:

      Error1.png

      "Cannot save the document. It may be opened by other applications. Close applications and try again. You may also use saveas to save it into a new document."

       

      File >> Save is grayed out, so depending on my need I'll either close the document (if there's no need to save) or I'll do Save As or Save As Copy and save it as something new. Both .indd and .idml produce the same result:

      When I close InDesign, the next time I open InDesign my preferences are gone, and I'm back to "factory default" as if I just installed the application. The only things that are kept are my workspaces and my PDF Presets.

       

      And usually when I open InDesign (and learn my preferences have been lost) I receive this error:

      Error2.png

      "The file 'ButtonLibrary.indl" is already in use by another application. For multi-user access, close the file and then lock it using the File > Get Info command in the Finder."

       

      Unfortunately, I don't have access to lock or unlock those files (I have two - both for CS4). I should note that InDesign is generally the only application running that would have any of those documents or files open.

       

      Again, this does not happen often. It's never been on the same file. I'm able to save my document (as new or as a copy), but not normally (File > Save) as I had been with no issue. This isn't for every file, and it appears to be a random occasional error. But the fact that I lose my preferences is extremely frustrating and I don't understand what is causing it. Any clue how to fix it? Would appreciate any help.

       

      I ran disk repair and a permissions repair - anything found in those have been repaired.