2 Replies Latest reply on Feb 9, 2016 12:53 PM by mattm84359003

    PhoneGap Build API not building app despite 202 response

    mattm84359003

      Hi,

       

      I'm wondering if anyone has had success using the Phonegap Build API for triggering app builds?

       

      I'm POSTing as follows. I've replaced anything personal but happy to provide anything if it helps.

       

      curl -u matt@emailaddress.co.uk -X POST -d '' https://build.phonegap.com/api/v1/apps/123456/build?auth_token=xxxxxxxxxxxxxxxxxxx

       

      I'm using the token stored in my account rather than generating one on the fly.

       

      And I'm getting a 202 response back with the following data

       

      string(1366) "{"id":123456,"title":"App Title","package":"com.ionicframework.appname123","version":"0.0.2","build_count":10,"priv ate":true,"phonegap_version":"cli-5.2.0","hydrates":true,"share":false,"last_build":"2016- 02-02 07:33:29 -0800","description":"Check App","repo":"https://github.com/githubid/App.git","tag":"","debug":true,"link":"/api/v1/apps/123456","plugins":"/api/v1/apps/123456/plugin s","completed":true,"role":"admin","icon":{"filename":"icon-60@3x.png","link":"/api/v1/app s/123456/icon"},"status":{"android":"complete","ios":"complete","winphone":"skip"},"downlo ad":{"android":"/api/v1/apps/123456/android","ios":"/api/v1/apps/123456/ios"},"error":{}," install_url":"https://build.phonegap.com/apps/123456/install/abc123","share_url":"https://build.phonegap.com/apps/123456/share","collaborators":{"link":"/api/v1/apps/123456/collaborators","active":[{"id":111222,"role ":"admin","person":"matt@emailaddress.co.uk","link":"/api/v1/apps/123456/collaborators/222333"}],"pending":[]},"keys":{"android":null ,"ios":{"id":333444,"title":"Proclaim it Cert","platform":"ios","link":"/api/v1/keys/ios/444555","default":true},"winphone":null}, "logs":{"android":"/api/v1/apps/123456/logs/android/build","ios":"/api/v1/apps/123456/logs /ios/build","winphone":"/api/v1/apps/123456/logs/winphone/build"}}"

       

      So all looks good. But the app isn't building when I trigger this. I was wondering if it was because hydration was turned on and whether that impacts it. Or if anyone has any wisdom on what else to try.

       

      Because the code needs to be pulled from GitHub, I ran this call first to see if that made a difference, but it doesn't seem to. I get an identical response to the above.

       

      curl -u matt@emailaddress.co.uk -X PUT -d 'data={"branch":"Master"}' https://build.phonegap.com/api/v1/apps/123456?auth_token=xxxxxxxxxxxxxxxxxxxx

       

      Thanks,

       

      Matt