23 Replies Latest reply on Jul 13, 2016 7:35 AM by Szalam

    Blinking Composition Window

    lehestro Level 1

      Another project, another annoying CC issue. This time it's in After Effects. This has sadly become the norm with Adobe. But enough of that – on to the issue!

       

      I am getting a blinking composition window, wherein every time I do anything (even move things with the hand tool), my composition window goes blank. Not black, but blank, like there's no composition at all (EXCEPT, strangely, my masks stay where they are). I've included a video to show the issue. Strangely this wasn't issue until I was halfway through my timeline.

       

      Now I am running a green screen key (using Primatte 5.1.3, the latest as of this writing) on 6k .r3d Red Dragon files, so it is a bit intensive. Still, rather odd that my images would just drop out. Restarting After Effects so far is the only way to fix this, but now I'm having to restart every minute or so.

       

      I've tried clearing my image cache and disk cache, which seems to help sometimes, sort of. Can't say for sure. I've also deselected "Reduce Cache size when system is low on memory" which helped a bit. I saw on Creative Cow that was causing similar problems.

       

      I'm running CC 2015, whatever the latest build is as of the time of this post, on a 2015 Macbook Pro 2.5Ghz i7 El Capitan, 16GB RAM, 13GB allocated to Adobe stuff.

       

      Much obliged for any help.

       

        • 1. Re: Blinking Composition Window
          Szalam Adobe Community Professional & MVP

          Gah! That would be annoying to work with!

           

          And you said it's doing this in version 13.7.0 of AE? (I always ask folks to double-check because sometimes the CC app doesn't push updates as reliably as one might expect.)

           

          Does it do it if you don't use Primatte in the comp? I mean, try Keylight or one of the other keying effects built into AE just to see if it behaves similarly.

           

          Have you tried this in CC 2014 to see if it behaves better? AE CC 2015 is a major re-architecture, separating the renderer from the UI for the first time in AE's 20+ year history. This is a big job and it's clearly still in progress. It's a necessary step for improving After Effects performance, but it's taking a while and multiple versions for them to get through. So, during this time of transition as they're introducing elements of the new architecture, sometimes it may be easier to use the older version to get a job done.

          How to Find and Install Previous Version of Adobe Apps in CC 2015

          • 2. Re: Blinking Composition Window
            Szalam Adobe Community Professional & MVP

            Ooh, also, in CC 2015 check your preferences for using hardware to accelerate panels. And try switching that option to see if it makes a difference.

            • 3. Re: Blinking Composition Window
              lehestro Level 1

              Hey Szalam, thanks for taking a peak at this issue. It is AE 13.7.0.124 to be precise. The issue does not seem to occur with keylight, so perhaps the issue lies with the plugin code itself. However, I would think that not the case, however, as other layers in the comp that do not have primatte added to them also disappear.

               

              I don't have a version of CC 2014. Is it possible to get one still? I have a creative cloud membership. So thank you for the link.

               

              Also – I'm unfamiliar with the hardware accelerate panels preference. Can you point me to where that is?

               

              Many thanks.

              • 4. Re: Blinking Composition Window
                Szalam Adobe Community Professional & MVP

                lehestro wrote:

                 

                The issue does not seem to occur with keylight, so perhaps the issue lies with the plugin code itself. However, I would think that not the case, however, as other layers in the comp that do not have primatte added to them also disappear.

                 

                I'm not thinking it's the effect itself causing the layers to which it's applied to ghost, I'm wondering if something about it being applied at all is causing the issue. Which may be the case. Have you checked to see if there's an update to that plugin? With AE's massive under-the-hood changes that began in CC 2015, some plugins have needed to be updated to behave.

                 

                lehestro wrote:

                 

                I'm unfamiliar with the hardware accelerate panels preference. Can you point me to where that is?

                 

                 

                 

                The Hardware Accelerate Composition, Layer, and Footage Panels option is in Preferences > Display

                • 5. Re: Blinking Composition Window
                  sskaz Level 1

                  Any updates on this, @lehestro? I had a very similar, if not identical, problem using CC 2015 13.7 in a keying comp (very possibly Primatte v5.1.3, I'm offsite and can't check at the moment). I chalked it up to my likely-unsupported Hackintosh (10.10.5, Radeon HD 6850).

                  • 6. Re: Blinking Composition Window
                    lehestro Level 1

                    I wish I could say there has been. I've not had a chance to download CC 2014 yet – I've just been trying to slog through this to meet a deadline. I've written to Red Giant as well to see if this is a known issue for them on their software.

                     

                    Whatever it is, all evidence points to it being a memory issue of some sort. When I look at it again today, I will test out Szalam's advice on the Display preferences' hardware acceleration issue.

                     

                    It should be said that unchecking the "Reduce cache size when memory is low" option in the Memory preference pane did make a substantial difference (though, still not a workable one, unfortunately).

                    • 7. Re: Blinking Composition Window
                      lehestro Level 1

                      So the issue continues, regardless of the Display Preference hardware acceleration being selected. What's more it is also occuring on my 2013 Mac Pro with 32GB RAM. I'm not sure what the issue is now.

                      • 8. Re: Blinking Composition Window
                        Szalam Adobe Community Professional & MVP

                        I would suggest filing a bug report so that the AE team can get eyes on the issue as well: Feature Request/Bug Report Form

                        In the meantime, it shouldn't take much time to install CC 2014, install your plugins to it, and at least try opening your project in it. It might help you meet your deadline more quickly and, if not, you won't have wasted much time.

                        • 9. Re: Blinking Composition Window
                          lehestro Level 1

                          Good advice. That's what I'm going to do.

                          One more note – it isn't Primatte causing the issue. If I turn off the effect on all layers the problem persists.

                          • 10. Re: Blinking Composition Window
                            lehestro Level 1

                            Well I have not had a chance to work in CC 2014 just yet. I'm still in the middle of this project, but there was an interesting development – I have a windows partition on my mac pro, and tried working in that. WORLD of difference. So perhaps it is an issue native to OSX. Strange that software would run better on an OS not built with my hardware in mind, rather than one developed directly for it, but the proof is in the proverbial pudding. I have a friend telling me I need to switch back to Windows after 12 years on macs. Perhaps he's right.

                            • 11. Re: Blinking Composition Window
                              sskaz Level 1

                              Well I won’t say switching to Windows is the best solution, but whatever works to get your work done is valid solution!


                              I haven’t had time to turn on this machine until today and it took some time just to get it to start happening again. For whatever reason, I’m only seeing it in one project file and only when I have Hardware Accelerate Composition, etc. Panels enabled. If that’s the solution for me, I’ll take it.

                              • 12. Re: Blinking Composition Window
                                lehestro Level 1

                                I should say that Szalam's advice to try CC2014 also worked. I don't have that problem there either (though it still runs a lot slower than Windows, but that's neither here nor there).

                                • 13. Re: Blinking Composition Window
                                  lehestro Level 1

                                  Sorry to post so piecemeal, but I just realized that one notable piece of information is that AE for some reason is never tapping into more than 7GB of RAM, more often 6GB. Usually it's around 16 under normal working conditions. It's definitely a memory issue. Once it starts happening my RAM previews become either super short (a few frames) or so short that I get the error "AE needs at least 2 cached frames for to preview". I filed all this info in a bug report, so we'll just have to see I guess.

                                  • 14. Re: Blinking Composition Window
                                    sskaz Level 1

                                    I didn’t notice how much RAM exactly was being used, but not long after the blinking returned, I got a lot of out of memory errors, too:

                                    Screen Shot 2016-02-15 at 8.46.25 pm.pngScreen Shot 2016-02-15 at 8.24.29 pm.png

                                     

                                    And this a couple times, which seemed to be a warning that the memory errors were about to begin:

                                    Screen Shot 2016-02-15 at 8.46.18 pm.png

                                    • 15. Re: Blinking Composition Window
                                      missjen818 Level 1

                                      I too am getting blinking frames or no picture at all when I try to 'scrub' the timeline.  Only started last week when I updated to AE 2015 (13.7). Doesn't matter if it's Primatte Keyer, Keylight or Color Key.   In fact, I don't have to have any plug ins on my comps.  I've turned off Cache completely and empty any memory it's storing.  I've tried zapping the PRam. 

                                      Multiple error messages - see attachments

                                      I have to restart AE every 10 min (with much difficulty at times because error messages won't go away!).    I am in the middle of a project as well on the latest MacPro with 32 gig of RAM, OSX 10.9.5.   Working in 1080p. 

                                      UGH!!! Can't take it!   As a last resort I will try to install AE 2014 as Lehestro has suggested....  and try to call Adobe tomorrow....

                                      Screen Shot 2016-02-17 at 6.31.40 PM.pngScreen Shot 2016-02-17 at 8.15.06 PM.pngmemory.png

                                      • 16. Re: Blinking Composition Window
                                        Jake Bastian Level 1

                                        I'm following this thread.  I'm currently on Yosemite and am getting all the errors mentioned here so it seem El Capitan is no longer the problem, it's just CC 2015.  Guess it's time to get the best OS available and keep checking back here for when Adobe fixes all these problems.

                                        • 17. Re: Blinking Composition Window
                                          muskelberge

                                          Ugh, I'm having exactly the same problem on OSX Yosemite with AE CC2015. It drives me nuts. Its like driving blind. Tried everything mentioned above without success. Guess I'll have to switch back to CC2014 as suggested.

                                          • 18. Re: Blinking Composition Window
                                            Szalam Adobe Community Professional & MVP

                                            muskelberge wrote:

                                             

                                            Ugh, I'm having exactly the same problem on OSX Yosemite with AE CC2015. It drives me nuts. Its like driving blind. Tried everything mentioned above without success. Guess I'll have to switch back to CC2014 as suggested.

                                            Double-check your version number. If it's not 13.7.2, you're not running the latest (The CC app often doesn't let people know abou tupdates. I've seen a lot of people on this forum recently who had 13.5.0 and thought they were on the latest becaue the CC app said they were.

                                             

                                            If you are on 13.7.2, using CC 2014 is probably your best bet. However, take heart! The next version of AE (coming "soon") has a new preview architecture that is meant to be more stable. (For the past three years, the new version of AE has come out towards the end of June, if memory serves. So, hopefully, it'll be the same this year and the new version will arrive in three weeks or so. Although, if they have to take a bit longer to iron out bugs, I'm totally okay with that!)

                                            • 19. Re: Blinking Composition Window
                                              muskelberge Level 1

                                              Hey Szalam,

                                               

                                              thanks for your answer. My version is 13.7.2.3. So I guess it'll be CC2014 for me for a couple of weeks.

                                               

                                              Cheers!

                                              • 20. Re: Blinking Composition Window
                                                Szalam Adobe Community Professional & MVP

                                                That sucks!

                                                Hopefully the new version comes out soon and hopefully it makes everything better.

                                                • 21. Re: Blinking Composition Window
                                                  muskelberge Level 1

                                                  Just a little update for everyone who might be finding this thread like I did. Hopefully someone from Adobe: I updated to El Capitan and AE 2015.3 (Version 13.8.0.144). And I'm still having this bug on both CC2015 and CC2015.3. It makes working with After Effects a real pain. Looks like I'll be stuck with CC2014 for quite a while.

                                                  • 22. Re: Blinking Composition Window
                                                    sskaz Level 1

                                                    Thanks for checking in. I’m betting it’s an issue with AMD graphics cards. Just a shot in the dark, but not unlikely given some of the other display issues I’ve seen reported on these boards are typically AMD users.

                                                    • 23. Re: Blinking Composition Window
                                                      Szalam Adobe Community Professional & MVP

                                                      sskaz wrote:

                                                       

                                                      I’m betting it’s an issue with AMD graphics cards. Just a shot in the dark, but not unlikely given some of the other display issues I’ve seen reported on these boards are typically AMD users.

                                                      I agree as to the likely culprit. But it only happens on a few systems. If this were widespread, we would have a lot more threads like this. I wonder what's different with these few machines that is causing the issue.

                                                       

                                                      Try unchecking (or if it's unchecked already, try checking) the preference to use hardware to accelerate panels, etc. and see if that helps/hinders/does nothing.