5 Replies Latest reply on Oct 8, 2012 6:22 AM by Anit_Kumar

    Scorm 1.2 output not working in LMS

    Brice235i Level 1
      Hi, I am attempting to use Presenter courseware in DOTs LMS. Unfortunately when I launch the content I get a blank screen. DOTS is loading the SCORM (1.2) content correctly (i.e. it launches the URL as per the Manifest file). The problem seems to be within the SCORM content itself.
        • 1. Re: Scorm 1.2 output not working in LMS
          Brice235i Level 1
          Hi, I'm replying to my own post as I've worked it out with the help of my LMS support team. It turns out that the Adobe Presenter content is not actually scorm 1.2.

          The Manifest file produced by Presenter is correct for SCORM v1.2 but the generated Javascript file is not.

          The ../scorm_support/scorm_support.js file needs to be ammended.
          This below line...
          //var g_nAPI = 0; // type of API to start searching for; allowable values: 0 - SCORM 2004; 1 - SCORM 1.2 (or 1.1)

          needs to be changed to force it to use SCORM v1.2, see below:
          var g_nAPI = 1; // type of API to start searching for; allowable values: 0 - SCORM 2004; 1 - SCORM 1.2 (or 1.1)

          Hopefully there will be an update to correct this?
          • 2. Re: Scorm 1.2 output not working in LMS
            robva65 Level 2

            Hey Brice,

             

            I wouldn't agree with that statement in it's entirety.  It is SCORM 1.2 Conformant, because I've personally run ADL tests against Presenter content for a variety of environments. Although it's true that SOME LMS platforms don't play "nicely" with Presenter content, it actually depends on the LMS you're deploying on.

             

            We've successfully deployed on Knowledge Planet, Docent 6.5 GeoLearning and Blackboard, although with BB there were some variables that needed to be massaged in order to work correctly.

             

            What environment are you publishing/posting to, b/c that would certainly help with regard to specific LMS platforms.

             

            Rob

            • 3. Re: Scorm 1.2 output not working in LMS
              Pete Vojtik Level 1

              Hey Brice,

               

              Did changing the value from 0 to 1 resolve your issue?

               

              We're running a Docent 6.5 LMS and we seem to encounter issues with our Presenter published SCORM 1.2 courses.  However, other courses published with Articulate or from other vendors using SCORM 1.2 don't seem to have these issues.

               

              Thanks!

              • 4. Re: Scorm 1.2 output not working in LMS
                Sayujr

                Brice235i wrote:

                 

                Hi, I'm replying to my own post as I've worked it out with the help of my LMS support team. It turns out that the Adobe Presenter content is not actually scorm 1.2.

                The Manifest file produced by Presenter is correct for SCORM v1.2 but the generated Javascript file is not.

                The ../scorm_support/scorm_support.js file needs to be ammended.
                This below line...
                //var g_nAPI = 0; // type of API to start searching for; allowable values: 0 - SCORM 2004; 1 - SCORM 1.2 (or 1.1)

                needs to be changed to force it to use SCORM v1.2, see below:
                var g_nAPI = 1; // type of API to start searching for; allowable values: 0 - SCORM 2004; 1 - SCORM 1.2 (or 1.1)

                Hopefully there will be an update to correct this?

                Where exactly is this file "./scorm_support/scorm_support.js"... am not able find it? can anyone tell me the exact directory location for Presenter 8?

                • 5. Re: Scorm 1.2 output not working in LMS
                  Anit_Kumar Adobe Employee

                  The scorm_support.js is available inside the published output/scorm_support/ folder.