1 Reply Latest reply on Jan 24, 2017 7:11 AM by danielw71296653

    setting up starling with flash builder 4.7 problems

    Phoenix-Griffin Level 1

      I followed the instructions here:

       

      https://helpx.adobe.com/flash-builder/kb/overlay-air-sdk-flash-builder.html

       

      I clicked File -> New -> ActionScript Project

      Then I called my "project StartingStarling01" and made it a Web Application.

      I clicked Next -> Add SWC -> browse, then located my Starling.SWC file in the Program Files in my C drive that. I had downloaded the Game SDK from my Creative Cloud account: "C:\Program Files (x86)\Adobe Gaming SDK 1.4\Frameworks\Starling\Starling-Framework\starling\bin"

      I clicked Finish.

       

      I created these classes:

       

      import flash.display.Sprite;
      import starling.core.Starling;

      [SWF(width="400", height="300", frameRate="60", backgroundColor="#ffffff")]
      public class StartingStarling01 extends Sprite
      {
         private var _starling:Starling;

         public function StartingStarling01()
         {
         _starling = new Starling(Game, stage);
         _starling.start();
         }
      }

       

      import starling.display.Sprite;
      import starling.text.TextField;

      public class Game extends Sprite
      {
         public function Game()
         {
         var textField:TextField = new TextField(400, 300, "Welcome to Starling!");
         addChild(textField);
         }
      }


      But I get all these problems:


      Capture.PNG

      And when I run the file it comes up with this in my browser:



      Capture2.PNG

      What have I done wrong and how do I fix it please?



        • 1. Re: setting up starling with flash builder 4.7 problems
          danielw71296653

          I don't know if you are still interested but if you clean Project > clean the project it fixed the errors I had. When learning a framework it is a good idea to link to the source folder of the framework, that way you benefit from viewing the source code in the package explorer. After you are ready for the release version use the swc files.

           

          To fix the error in the web browser you have to edit the index.templete.html in the root of your project.

          In the script tag inside the head element add the following params.wmode = "direct"; You will see other param values being set just insert the line there.

           

          Hope this help.