4 Replies Latest reply on Jun 12, 2008 7:48 AM by Peter Grainge

    Problem displaying WebHelp built from RoboHelp HTML Editiion

    wgmeisheid Level 1
      I have a project I want to transition out of RoboHelp for Word but when I build the files in RoboHTML in my extremely locked down environment (I work on a secure network) I get errors when I try to display the WebHelp that does not occur with my RoboHelp for Word build.

      The errors appear to relate to pathing problems for the Contents, Index, and Find. All three selections give me Line 728, Char 3, Error Object Expected, Code 0, URL ends in whtdhtml.htm. As I click on other items in the Contents I get the same error. I get the same error when I try to open a book. After a book opens the TOC freezes after getting Error:84 Unspecified Error. I cannot close any books after getting the Error: 84. Clicking on a page displays the page fine.

      Nothing displays in the Index. Typing in the Index text box gives me Line 1096, Char 3, Error faFakes[…].nB’ is null or not an object, Code 0, URL ends in whibody.htm. If I come back to to the Index after clicking elsewhere, nothing still displays but I do not get the error, however, I still cannot find anything.

      When I type something in Search, it appears to return results normally, but when I try to access a result I get Line 619, Char 2, Object Expected, Code 0, URL of the file I am trying to access.

      Has anyone ever seen anything like this? It has to be in my locked down XP setup that affects the build from RoboHTML, possibly screwing up the XML files or if something is actually written into the JS files, messing with them. Someone suggested our environment may have put something in an unfamiliar place and the build gets munged. It has to be the build process since WebHelp works fine when created from RoboHelp for Word.