4 Replies Latest reply on Feb 18, 2016 11:11 AM by whitebalanceinc

    Rending out exactly what i see in preview monitor, removing bad de-interlace lines

    whitebalanceinc
      Alright, here is one for you AE gurus.

       

      THE PROBLEM I'M TRYING TO FIX:

      Client delivered a 29.97 progressive QT Uncompressed 10 bit YUV file.  However it looks like they imported some clips into their FCP7 project and cut them into their sequence without properly de-interlacing.  So randomly through out the quicktime I come across shots like with this one, with horizontal field issue looking thing:

       

      Screen Shot 2016-02-17 at 8.56.57 PM.png

       

      I THINK I SOLVED THE PROBLEM IN AFTER EFFECTS:


      I import QT into AE, select the clip, interpreted footage.  The only thing I change is:

      Conform to frame rate 29.97

      But if you look at the screen grab below, it looks like all I've done is change the frame rate from (29.970 fps) to 29.97.  No difference, right?  Don't know what the extra 0 means.

      Screen Shot 2016-02-17 at 9.02.59 PM.png

       

      I then right click the QT and make a composition, and to my surprise the problem is gone when I play the composition in the preview window.  I have no idea what I changed, but horizontals bad de-interlace lines go away on a progressive scan computer monitor as I play the composition.  Even gone when I step frame.  In addition, I can play out the composition, SDI, through my BlackMagic 4k Extreme card, and record the SDI signal to my BlackMagic HyperDeck SSD Drive.  I then import the new test Quicktime I recorded, and the lines are gone.


      Screen Shot 2016-02-17 at 8.58.03 PM.png

       

      SO WHAT'S THE PROBLEM?:


      So why don't I just play out and record to SSD?  AE will not playback the entire file in realtime, even with 40 gigs of ram assigned to AE.  So I get stutter, and would have to start and stop all the time for a 30 minute show.

       

      I also cannot render out a file that looks like the preview monitor.  Either I get the same interlace issue, or a new interlace issue that looks like this:


      Screen Shot 2016-02-17 at 10.46.47 PM.png

       

      Since I don't think there are fields in the original file, AE must be doing something with shutter angle and/or motion blur.

       

      I have a suspicion that the QT plays nicely in the preview monitor because of the motion blur settings available in advanced composition settings:

       


      Screen Shot 2016-02-17 at 10.08.21 PM.png


      Are the motion blur settings above only operating in the preview monitor, and do not affect the file when rendered out?  I tried various force motion blur effects, but they only had Shutter Angle and Samples Per Frame options, no options for Shutter Phase or Adaptive Sample Limit.  I want to render out what I see in the preview monitor and what I see when I play out of my decklink extreme 4K card.

       

      In other words, render out exactly what the composition is, how do I make this happen?


      Is there anything like render same as comp, or a mixdown feature?

       

      Thanks for reading this far.

        • 1. Re: Rending out exactly what i see in preview monitor, removing bad de-interlace lines
          Mylenium Most Valuable Participant

          Um, well, previewing your footage at half res eliminates/ interpolates every second line. There is no magic in that. You need to work at full res and 100% zoom. As to your original problem - you will have to cut the segments up and apply an effect like RevisonFX FieldKit to de-interlace selectively.

           

          Mylenium

          • 2. Re: Rending out exactly what i see in preview monitor, removing bad de-interlace lines
            chrisw44157881 Level 4

            strange you did not post about your interpret field settings and pulldown settings. If you check, the image might be essentially interlaced by AE. upper or lower field is determined by the footage type, size, SD,HD etc.

            like Mylenium said, full res needs to see the frames and not draft mode either.

             

            QT probably deinterlaced too.

             

            Since you said the interlacing goes away, I tend to think its not 23.976 footage with 3:2 pulldown or you'd run into a major cadence editing issue. I believe you have standard interlaced 29.97 footage.

            • 3. Re: Rending out exactly what i see in preview monitor, removing bad de-interlace lines
              whitebalanceinc Level 1

              chrisw444157881,

               

              You were right the QT is in fact interlaced, top field first.  The only app that would allow me to see this is compressor.  Every other app including Telestream Switch said it was progressive.

               

              So I de-interlaced with interpret footage in AE and looks good.

               

              So I have 2 more questions:

               

              1.  What app do you use to analyze QTs, especially if header info might be incorrect, like I suspect with this file?  I was using VideoSpec which was great:  VideoSpec for Mac | MacUpdate

               

              Sadly, they are no longer updating for new OS.  So I'm trying to replace it, and Telestream's Switch isn't up to the task.

               

              2.  I still don't understand why AE can play out the QT, SDI, via my blackmagic card and the interlacing issue disappears without me having to de-interlace in the interpret footage dialog.  I record that output signal to a blackmagic SSD drive, import the new quicktime, and the interlacing is gone.  I would have ran with this solution, if AE could have sustained real time playback.

               

              So you and Mylenium said if the preview monitor is set to half resolution, draft, or not 100% zoom, that magically gets rid of de-interlacing issues.  So setting preview monitor to half resolution somehow allows AE to de-interlace the file on play out, or is AE intelligently de-interlacing on it's own when playing out SDI?  Trying to understand why play out de-interlaced the file, or added motion blur

               

              I guess I don't get it for a couple of reasons.  1, I could see the de-interlace issue in the preview monitor at half resolution, when I simply loaded the clip.  However, once I loaded the composition into the same half res preview monitor, the interlacing goes away.  2, I think the motion blur settings in the advanced tab are affecting the preview monitor.  Or there is some composition setting I'm not transferring in the render queue.  Although I tried a bunch.

               

              If I load the same clip in Symphony, preview monitor also looks good, just exports that remains a problem.

               

              Since these interlacing issues only exist on progressive scan (computer) monitors, not broadcast monitors, is the preview window for Comps in AE somehow mimicking a broadcast monitor?

              • 4. Re: Rending out exactly what i see in preview monitor, removing bad de-interlace lines
                whitebalanceinc Level 1

                Sorry meant to say "play out deinterlaced the file and added a nice little motion blur" again without me doing much.  This is the file I created recorded into blackmagic ssd

                 

                Screen Shot 2016-02-18 at 11.07.56 AM.png