2 Replies Latest reply on Feb 20, 2016 7:03 AM by Steve Grisetti

    How do I stop videos from lagging when I playback in the editor?

    Leeat

      Hi,

       

      I have been using adobe elements for awhile and the visual has pretty much always lagged when I try to play it back. When I render the video and try to play it back the audio sounds normal but the visual lags and I pretty much have to 'blind edit' because I can't really see what my transitions and cuts look like. I am trialing camtasia studio and it's also lagging so I'm thinking the problem is my computer rather than the editing system.

       

      I have edited footage from my iphone 6 and also from a cannon and they all lag when I play back footage in the editor. I am using windows 8, (I think 64 bit), I have an Asus laptop, Intel core i3

       

      What can I do to make the playback run smoothly so I can actually see what I'm editing?

       

      Thanks,

      Lee'at

        • 1. Re: How do I stop videos from lagging when I playback in the editor?
          whsprague Level 4

          An i3 is not strong enough for smooth editing, especially if it is HD video.  Making it worse is that you probably have a "normal" disk drive.  Video editing needs a fast one.  I have an i5 ASUS laptop that works, but barely.  I have a bigger i7 laptop with an SSD drive and it works very well. 

          • 2. Re: How do I stop videos from lagging when I playback in the editor?
            Steve Grisetti Adobe Community Professional

            I agree with Bill. i3 laptops probably don't have the power to edit video well.

             

            Although it kind of depends on which i3 you have, what model of camcorder you're using and what format and resolution the video is and which version of the program you're editing it with.

             

            It also matters whether or not your project is set up to match your video specs. If your project settings match your video specs, you will NOT see a yellow-orange line along the top of the timeline, above your clips, when you add a new clip to your timeline in Expert view. Is that the case in your project?

             

            Also, have you ensured you have Quicktime, per the program's system requirements?