38 Replies Latest reply on Apr 11, 2018 8:29 AM by shaunh57022627

    CEPHtmlEngine issues

    shanerees82 Level 1

      Ever since i upgraded to a 2015 Macbook Pro Retina and installed Adobe CC I started have issues with my fan running at high speed while using apps, so after many trials and conversations with adobe customer care and help desk i managed to work out that if i completely deleted the CEPHtmlEngine files it removed the startup menus and CC libraries panels from all apps so i uninstalled the software then reinstalled of course the issue came back so found that disabling cc sync it actually fixed the fan issues and i was able to use cc libraries but them today while i had indesign and photoshop both running the fan issue arose again until i closed 1 app down, not ideal as sometimes you want to be ale to flick between apps. This issue never happened on my 2012 macbook pro i use to be able to have about 3 apps open at once. Never any fan issues. Any ideas is this is a CEPHtmlEngine bug? Hopefully adobe are aware and are looking into it. Cheers AdobeCC

        • 1. Re: CEPHtmlEngine issues
          David__B Adobe Employee

          Hi Shane,

           

          Sorry to hear about your difficulties. Could you confirm you have the latest version of the Creative Cloud app installed? You should be able to check from the Creative Cloud app from the Preferences. The latest version is 3.5.1.209.

           

          Also, just to ensure I understand, a few additional questions:
          - If you look in the Activity Monitor does it show excessive CPU usage?

          - If you close the Photoshop and InDesign does the behavior persist?

           

          Please get back to me when you get the chance, thanks
          - Dave

          1 person found this helpful
          • 2. Re: CEPHtmlEngine issues
            shanerees82 Level 1

            Hey yes have version 3.5.1.209

            I've included a screen shot of my activity monitor while both programs are running

            Also fan noise reduces once programs have been closed/or if they lie idle in background. Hope this helps.

            Screen Shot 2016-02-23 at 9.19.49 AM.png

            • 3. Re: CEPHtmlEngine issues
              vonwi Level 1

              Hi Shane & Dave,

               

              Since one of the last CC updates I have exactly the same annoying issue (MacBook Pro Retina 15" End 2013, MacOS 10.11.3 El Capitan); fan noise at high level and CEPHtmlEngine(s) at 110% CPU; that means working at slow motion. Latest CC 3.5.1.209 installed. Regardless of which Adobe tool is opened (PS, AI, ID). The search for "cephtmlengine" shows that we are not alone...


              If you need any further info please let me know.

               

              Cheers,

              Frank

              • 4. Re: CEPHtmlEngine issues
                shanerees82 Level 1

                cheers even though it sucks, it is good to know it's just not mine.

                • 5. Re: CEPHtmlEngine issues
                  Fabiano Bastos Level 1

                  I want a solution to my problem...


                  Creative Cloud app version 3.5.1.209

                  iMac 27 inch Mid 2010

                  Macbook Pro early 2012



                  Monitor atividade.jpg

                  • 6. Re: CEPHtmlEngine issues
                    masterguggi Level 1

                    Hi, i have the same problems AI, ID and PS. CPU over 100% when these programs are only open. My Retina is hot like a stove!!!!!!!

                    Adobe you have to solve this problem asap!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

                    • 7. Re: CEPHtmlEngine issues
                      Vektoren Level 1

                      I have the same issue on my Thinkpad with Windows 10 and all CC applications... @Adobe: Please fix this issue fast

                      • 8. Re: CEPHtmlEngine issues
                        vonwi Level 1

                        InDesign update today: V.2015.2 | Build 11.2.0.99

                         

                        Still the same issue (screenshot attached).

                         

                        activity_cepthtmlengine.png

                         

                        Cheers,

                        Frank

                        • 9. Re: CEPHtmlEngine issues
                          masterguggi Level 1

                          Hi,

                          if ID, PS or Ai is closed completely, CEPHtml Engine Helper runs normal. If i start one of these programs, CEPHtml Engine Helper is over 100% (without working in the program).

                          • 10. Re: CEPHtmlEngine issues
                            huid31332308 Level 2

                            Dear All,

                             

                            Could you please refer to this post and see whether it fixes your problem?

                            CEPHtmlEngine slows Computer (Mac) and solution.

                            • 11. Re: CEPHtmlEngine issues
                              Cristian Contreras Level 1

                              same problem here. macbook pro retina 15, mid 2014. OSX 10.11.3

                               

                              Screen Shot 2016-02-23 at 15.23.28.jpg

                              • 12. Re: CEPHtmlEngine issues
                                Vektoren Level 1

                                @huid31332308: The other thread does not provide any solution for Microsoft Windows users

                                • 13. Re: CEPHtmlEngine issues
                                  Vektoren Level 1

                                  Dear David,

                                   

                                  • Yes, in my case, the latest version of the Creative Cloud app is installed
                                  • Yes, if I open the Windows 10 Task Manager, I see a huge load for CEPHtmlEngine.exe
                                  • If I close e.g. Photoshop or Dreamweaver, the load is gone. Thus, no -- it does not persist. But for example, if I start Photoshop and Dreamweaver together, I get the double load (witch means, the system is not usable any longer)
                                  • In case of Photoshop, I can disable the plug-in system (Preferences -> Plug-Ins -> Disable "Allow Extensions to Connect to the Internet" and disable "Load Extension Panels"). Afterwards, everything is fine ... but Photoshop is missing many features e.g. Export as, etc.
                                  • In case of Dreamweaver, I can re-name the CEPHtmlEngine.exe to e.g. CEPHtmlEngine.exe.disabled in order to force Dreamweaver to not use that!


                                  A solution would be good

                                  • 14. Re: CEPHtmlEngine issues
                                    vonwi Level 1

                                    huid31332308 schrieb:

                                     

                                    Dear All,

                                     

                                    Could you please refer to this post and see whether it fixes your problem?

                                    CEPHtmlEngine slows Computer (Mac) and solution.

                                     

                                    Thanks, the following workaround seems to be a solution .. it works.

                                     

                                    Could you please try out the private build of Design Library (Shared Files - Acrobat.com), which has a potential fix for the CPU usage issue?

                                    1. Move the old Design Library extension to somewhere else (move to your Desktop for example):

                                    • Photoshop: /Applications/Adobe Photoshop CC 2015/Adobe Photoshop CC 2015.app/Contents/Required/CEP/extensions/com.adobe.DesignLibraryPanel.html/
                                    • Illustrator: /Applications/Adobe Illustrator CC 2015/CEP/extensions/com.adobe.DesignLibraries.angular/
                                    • InDesign: /Applications/Adobe InDesign CC 2015/Resources/CEP/extensions/com.adobe.DesignLibraries.angular/

                                    2. Download DL.zip from Shared Files - Acrobat.com, then extract it to

                                    • Photoshop: /Applications/Adobe Photoshop CC 2015/Adobe Photoshop CC 2015.app/Contents/Required/CEP/extensions/
                                    • Illustrator: /Applications/Adobe Illustrator CC 2015/CEP/extensions/
                                    • InDesign: /Applications/Adobe InDesign CC 2015/Resources/CEP/extensions/

                                     

                                    The final directory structure should look like:

                                    .../extensions/

                                                          |-DL/

                                                                 |-CSXS/manifest.xml

                                                                 |-index.html

                                                                 |-.....

                                     

                                     

                                     

                                    Cheers,

                                    Frank

                                    • 15. Re: CEPHtmlEngine issues
                                      Vektoren Level 1

                                      vonwi schrieb:

                                       

                                      huid31332308 schrieb:

                                       

                                      Dear All,

                                       

                                      Could you please refer to this post and see whether it fixes your problem?

                                      CEPHtmlEngine slows Computer (Mac) and solution.

                                       

                                      Thanks, the following workaround seems to be a solution .. it works.

                                       

                                      Could you please try out the private build of Design Library (Shared Files - Acrobat.com), which has a potential fix for the CPU usage issue?

                                      1. Move the old Design Library extension to somewhere else (move to your Desktop for example):

                                      • Photoshop: /Applications/Adobe Photoshop CC 2015/Adobe Photoshop CC 2015.app/Contents/Required/CEP/extensions/com.adobe.DesignLibraryPanel.html/
                                      • Illustrator: /Applications/Adobe Illustrator CC 2015/CEP/extensions/com.adobe.DesignLibraries.angular/
                                      • InDesign: /Applications/Adobe InDesign CC 2015/Resources/CEP/extensions/com.adobe.DesignLibraries.angular/

                                      2. Download DL.zip from Shared Files - Acrobat.com, then extract it to

                                      • Photoshop: /Applications/Adobe Photoshop CC 2015/Adobe Photoshop CC 2015.app/Contents/Required/CEP/extensions/
                                      • Illustrator: /Applications/Adobe Illustrator CC 2015/CEP/extensions/
                                      • InDesign: /Applications/Adobe InDesign CC 2015/Resources/CEP/extensions/

                                       

                                      The final directory structure should look like:

                                      .../extensions/

                                                            |-DL/

                                                                   |-CSXS/manifest.xml

                                                                   |-index.html

                                                                   |-.....

                                       

                                       

                                       

                                      Cheers,

                                      Frank

                                       

                                      Thanks, Frank It works also for Windows 10... just the paths are different

                                       

                                      • Dreamweaver @Windows: c:\Program Files\Adobe\Adobe Dreamweaver CC 2015\configuration\CEPExtensions\com.adobe.DesignLibraries.angular\
                                      • Photoshop @Windows: c:\Program Files\Adobe\Adobe Photoshop CC 2015\Required\CEP\extensions\com.adobe.DesignLibraryPanel.html\

                                       

                                      Thanks for this solution

                                      1 person found this helpful
                                      • 16. Re: CEPHtmlEngine issues
                                        huid31332308 Level 2

                                        Hi,

                                         

                                        Adobe is aware of this issue and has been working on it. A fix is coming. Thanks!

                                        • 17. Re: CEPHtmlEngine issues
                                          huid31332308 Level 2

                                          Hi Vektoren,

                                           

                                          On Windows (I assume you are on Windows 64 bit), the folder to be removed and replaced are as blow:

                                          After Effects: C:\Program Files\Adobe\Adobe After Effects CC 2015\Support Files\Libraries

                                          Dreamweaver: C:\Program Files\Adobe\Adobe Dreamweaver CC 2015\configuration\CEPExtensions\com.adobe.DesignLibraries.angular

                                          Illustrator: C:\Program Files\Adobe\Adobe Illustrator CC 2015\CEP\extensions\com.adobe.DesignLibraries.angular

                                          InDesign: C:\Program Files\Adobe\Adobe InDesign CC 2015\Resources\CEP\extensions\com.adobe.DesignLibraries.angular

                                          Photoshop: C:\Program Files\Adobe\Adobe Photoshop CC 2015\Required\CEP\extensions\com.adobe.DesignLibraryPanel.html

                                          Premiere Pro: C:\Program Files\Adobe\Adobe Premiere Pro CC 2015\CEP\extensions\com.adobe.DesignLibraries.angular

                                          1 person found this helpful
                                          • 18. Re: CEPHtmlEngine issues
                                            stevenh14122618 Level 1

                                            Seems to work for me! thanks.

                                            • 19. Re: CEPHtmlEngine issues
                                              stermano Level 1

                                              I'm on a mac with the same issue. Anyone have a mac workaround?

                                              • 20. Re: CEPHtmlEngine issues
                                                vonwi Level 1

                                                Hello stermano,

                                                 

                                                you'll find the workaround incl. some new files for MAC users above (4-5 posts before yours). It's also marked as right answer.

                                                 

                                                Cheers,

                                                Frank

                                                • 21. Re: CEPHtmlEngine issues
                                                  stermano Level 1

                                                  Yes, I saw that right after I submitted my question. It worked great! I found the folder I needed in Dreamweaver (it's not listed above) and no more issues. Thanks!!

                                                   

                                                  /Applications/Adobe Dreamweaver CC 2015/configuration/CEP/extensions/

                                                  • 22. Re: CEPHtmlEngine issues
                                                    ramore07 Level 1

                                                    Thank you for this workaround. The same issue is occurring in Premiere Pro (using a PC).

                                                    • 23. Re: CEPHtmlEngine issues
                                                      mattltm Level 1

                                                      I had the same issue with CEPHtmlEngine using 120% CPU pretty much all of the time Photoshop was open.

                                                       

                                                      Followed the instructions here and it seems to have fixed the issue.

                                                       

                                                      27" 2010 iMac with 2.8Ghz i5 processor and 20GB RAM.

                                                      • 24. Re: CEPHtmlEngine issues
                                                        bentosan Level 1

                                                        thanks a lot! it helped with my problem. now my mac is quiet again!!!

                                                        i just could´t find the folder for photoshop! so i could not change the photoshop file. it work for indesign and illustrator. but as far as i have tested it my mac keeps quiet anyway ...

                                                        • 25. Re: CEPHtmlEngine issues
                                                          Cristian Contreras Level 1

                                                          b9tSceBaBJ.jpg

                                                            finally with the last update of InDesign CEPHtmlEngine problems are over.

                                                          online Library still operating.

                                                          • 26. Re: CEPHtmlEngine issues
                                                            Cristian Contreras Level 1

                                                            this is the official solution? no date ... do not know if this was applied in the last updates yesterday  :-/

                                                            https://helpx.adobe.com/x-productkb/global/high_cpu_usage_cephtmlengine.html

                                                            • 27. Re: CEPHtmlEngine issues
                                                              D700 Level 1

                                                              Hi Guys

                                                              Having the same problem,

                                                              Worked out that if I select the CEPHtmlengine in Activity monitor and click the x the engine will be deleted

                                                              This has solved the problem apparently? But what if I need to switch it back on again for some reason, like possible syncing?

                                                              How do I do that?

                                                               

                                                              FWIW, I rang the Adobe help line this afternoon, and he said that CEPHtmlEngine was not Adobe and couldn't help me?

                                                              .......Gary

                                                              • 28. Re: CEPHtmlEngine issues
                                                                CW Photography Level 1

                                                                It is a adobe problem, read this blog.

                                                                 

                                                                What is the "Adobe CEP HTML Engine"? It`s using too much from my processor.

                                                                 

                                                                Also a solution here from adobe.

                                                                 

                                                                https://helpx.adobe.com/x-productkb/global/high_cpu_usage_cephtmlengine.html

                                                                 

                                                                It has on the above link.

                                                                 

                                                                Adobe engineering is aware of the issue and plans to address it in a future update.

                                                                 

                                                                The phone support are wrong and should be educated by the engineering department to give out correct information and not be in the process of making a bug problem worse.

                                                                1 person found this helpful
                                                                • 29. Re: CEPHtmlEngine issues
                                                                  Oscar Ovalle Level 1

                                                                  Hello, I applied your solution to the CEP HTML Engine issue and my processor seems to be working normally now, but now checking the Task Manager I discovered multiple instances of the CEP HTML Engine when opening each CC App.  Is this a normal behavior?

                                                                   

                                                                  CPU has an ormal use but each CEP HTML Engine is using a certain amount of memory.

                                                                   

                                                                  My laptop has an Intel i5 CPU

                                                                  8GB of RAM

                                                                  and a ATI HD5470 GPU

                                                                  running on Windows 7 64 bits.

                                                                   

                                                                  Thank you.

                                                                   

                                                                  Screenshot 1.png

                                                                  • 30. Re: CEPHtmlEngine issues
                                                                    Plutomond Level 1

                                                                    I have the same issue with Photoshop CC 2017. Normal CPU usage but double or triple CEPHtmlEngine processes.

                                                                    Is there a fix yet? It doesn't interfere with my workflow or anything but still kinda trips me out.

                                                                    Thanks in advance!

                                                                     

                                                                    2016-12-30 14_18_54-Adobe Photoshop CC 2017.png

                                                                     

                                                                    i7-6700K CPU

                                                                    32 GB RAM

                                                                    nVidia 970

                                                                    Win10 Enterprise

                                                                    • 31. Re: CEPHtmlEngine issues
                                                                      justinleedero Level 1

                                                                      WINDOWS USERS ..  In short, just rename CEPHtmlEngine.exe & be done.

                                                                       

                                                                      In long form.....

                                                                       

                                                                      My system spec isnt stellar, its what corporate provided and im stuck with it (i7 3ghz +16gb ram + 5400rpm sled).

                                                                       

                                                                      Seeing the same as above on windows 7.  Any time photoshop 2017 is kicked up, 10+ instances of CEPHtmlEngine.exe are kicked up as well, with each allocating between 10-25mb of ram. 

                                                                       

                                                                      Before taking any action, photoshop startup was dog slow, and totally unresponsive for a good 3-5 minutes after startup.

                                                                       

                                                                      From what I read, CEPHtmlEngine.exe is trying to connect to the internet & what Adobe seems to have forgotten is that depending on any number of corporate firewalls, proxies, etc, the solution may not be effective or work at all, for a great many people, as these forums have clearly evidenced.

                                                                       

                                                                      This useless waste of system resources (memory and cpu threads & disk cycles) is not only asinine, to say the least, but also the usablilty of the software in this situation is suffering greatly, which is totally reprehensible.

                                                                       

                                                                      For months and months we've endured with no responses from adobe other than 'Try this hacker crap with your dir tree & maybe it'll work.'   Useless, Adobe. Totally forking useless.   I'll say this again.  Adobe's incredulity is totally asinine and reprehensible, from the standpoint of a paying/subscribing customer.  We pay you monthly fees. FIX THIS NONSENSE!

                                                                       

                                                                      In lieu of a solution from Adobe (those slackers!), I went and renamed CEPHtmlEngine.exe to CEPHtmlEngine.exe.BITEMEADOBE. 

                                                                       

                                                                      Now when I kick up photoshop 2017, its super fast to startup and no lag once loaded..   My problems are gone.

                                                                       

                                                                      Someone pointed out that some 3rd party extensions and the "export as" functions are disabled when after renameing CEPHtmlEngine.exe..  This is true, but this has not affected my workflow at all.  Those features (as well as CEPHtmlEngine.exe) are superfluous to Photoshop's core functionality anyway. 

                                                                       

                                                                      If I find that disabling CEPHtmlEngine.exe has adversely affected my workflow down the road I will report back with any alterntaives or workarounds i may discover.

                                                                      • 32. Re: CEPHtmlEngine issues
                                                                        ddshatto Level 1

                                                                        Adobe, is there any update to this?  I am getting multiple instances of the CEPHTMLEngine.exe showing in taskmanager and it is impacting the functionality of Illustrator

                                                                        • 33. Re: CEPHtmlEngine issues
                                                                          Spamhunter Level 1

                                                                          It's over two years since Adobe were "working on a fix" & I've got the same problem (InDesign 13.1 x64). My files just hang, I can only close them with Task Manager & then ID crashes next time I open it as it tries to load the same ones again with 14 "Adobe CEP HTML Engine" processes taking up 61% (and climbing) of 16GB.

                                                                           

                                                                          Update - Vonwi's solution seems to be working for now, but if this is a workaround instead of a version fix, what is the compromise?

                                                                          • 34. Re: CEPHtmlEngine issues
                                                                            David__B Adobe Employee

                                                                            Hi Spamhunter,

                                                                             

                                                                            This issue was resolved by updates. Could you try uninstalling and reinstalling the Creative Cloud app using the uninstaller app from here? Uninstall the Adobe Creative Cloud desktop application and then rebooting the computer. Also, after doing so please confirm you have any updates for the related product installed too, InDesign, Illustrator etc. Please let me know if you continue to see the issue after completing these steps.

                                                                            1 person found this helpful
                                                                            • 35. Re: CEPHtmlEngine issues
                                                                              mbkeahey Level 1

                                                                              David, I'm having this issue with InDesign as well. I've uninstalled/reinstalled CC. All of my apps are updated. No change. I have spent hours online searching for a solution and have tried all of the ones in this thread and the several others I found. Right now, with no extensions open, there are 14 Adobe CEP HTML Engines running and the disk usage is 100%. I cannot explain to you how frustrated I am.

                                                                              • 36. Re: CEPHtmlEngine issues
                                                                                David__B Adobe Employee

                                                                                Hi Mbkeahey,

                                                                                 

                                                                                Sorry to hear about all your frustration regarding this. Thanks for providing info regarding what you've tried already. A couple additional questions to better understand the situation.

                                                                                 

                                                                                • Has it always done this?
                                                                                • What operating and version are you using? Are all OS updates installed?
                                                                                • Do you have any anti-virus software running on the system? What product and version?
                                                                                • Did you have any other cloud storage client running (on the Taskbar or Menu Bar)i.e. OneDrive, iCloud, Dropbox, etc.?
                                                                                • Are you behind a firewall or using firewall software (None/Corporate/Local)?
                                                                                • Are you behind a proxy (Y/N)?
                                                                                • Do you log onto a domain?
                                                                                • Location where issue occurred (City, Country)?

                                                                                 

                                                                                I looked for any past cases where you interacted with support under the email address you're using here in the forums but didn't see any past history. Is this your first time contacted Adobe about the issue?

                                                                                 

                                                                                Please get back to me when you get the chance,

                                                                                 

                                                                                Thanks

                                                                                - Dave

                                                                                • 37. Re: CEPHtmlEngine issues
                                                                                  mbkeahey Level 1

                                                                                  Hi Dave. This is the first time I've contacted Adobe because it's a pretty recent development. I'm not sure when the problem started, but about three weeks ago it got to the point that it was running so slowly that I uninstalled/reinstalled hoping that would help. Earlier this week I uninstalled InDesign 2018 and reinstalled 2017, again, hoping the update was the problem, but still no change. In answer to your questions:

                                                                                  1. It hasn't always done this. As I said above, it's a fairly recent development. As for the CEPhtml running so many/much, I never checked it before because I had never heard of it until I came across this thread.

                                                                                  2. I use Windows 10, all updates installed.

                                                                                  3. I do have anti-virus: AVG free version and Malwarebytes. These aren't recent additions, though. I disabled the AVG for a bit but there was no change.

                                                                                  4. Dropbox is running, no iCloud or OneDrive. Again, not new.

                                                                                  5. The Windows firewall is on, but I disabled it for a while with no change.

                                                                                  6. No proxy.

                                                                                  7. No domain. Just me at home. (I have noticed it running slowly at my office, but haven't been there in a few days so that's tomorrow's problem).

                                                                                  8. I'm in Little Rock, Arkansas.

                                                                                   

                                                                                  Thanks for your help. -mbk

                                                                                  • 38. Re: CEPHtmlEngine issues
                                                                                    shaunh57022627 Level 1

                                                                                    Hi,

                                                                                     

                                                                                    I'm getting it as well on a Windows 10, I7 workstation, have 8 instances of the Adobe CEP HTML Engine running and Illustrator just hangs.

                                                                                     

                                                                                    It's pretty poor of Adobe I have to say.

                                                                                     

                                                                                    Shaun