3 Replies Latest reply on Feb 23, 2016 2:06 PM by smoothsea

    How do I stop text from snapping, when nothing is set to snap?

    YamRam Level 1

      For any new documents, all text snaps to some invisible grid. Nothing is set to snap. When I move a text box up, the copy doesn't move along with it, until the box moves a significant amount. And, leading also doesn't work - it seems to snap to a baseline grid, but baseline grid snapping is off. I've restarted InDesign, and the  computer. I've updated to the latest version of Indesign. The only workaround, sometimes, seems to be to use a very old file, or to turn all text into outlines. But that means I can't edit the text. How can this be resolved?

        • 1. Re: How do I stop text from snapping, when nothing is set to snap?
          smoothsea Level 3

          Hi,

           

          Snap to baseline grid is not an option that you can switch on or off - rather your paragraph style will contain an option of 'align to baseline grid'. Is that the difference?

           

          Regards,

           

          Malcolm

          • 2. Re: How do I stop text from snapping, when nothing is set to snap?
            YamRam Level 1

            Malcolm

            Hi. Thanks! I see under the Paragraph box, an option for "Only align first line to grid." Is there another align to grid option? However, that is left unchecked.


            But the problem might still lie somewhere in Paragraph styles - just can't figure out where. The paragraph styles seems to have a plus sign next to the "basig paragraph" style. When I double-click, it goes away, and the snapping problem is solved

             

            However, any new document has the same issue, and I have to do those steps again.

            • 3. Re: How do I stop text from snapping, when nothing is set to snap?
              smoothsea Level 3

              Hi,

               

              First of all, with no documents open, select your type tool and look in the paragraph and character controls along the top of your screen. You will see the baseline grid icons near the end of the paragraph options. If align to baseline grid is checked, then it will be on for all new documents. Instead, check Do not align to baseline grid. This will stop your problem happening in any new documents you create, but existing documents will need the change made within them.

               

              Secondly, it is best to avoid using the basic paragraph stylesheet - always make your own - you will have much more control over your document. You can make global changes throughout your document by changing your paragraph styles.

               

              Regards,

               

              Malcolm