2 Replies Latest reply on Oct 21, 2016 3:03 PM by Tim_Menke Branched from an earlier discussion.

    Deployment Failures with SCCM 2012 and Flash Player 20

    marcelp89471361

      I realize this thread is old, but the issue is still on going! I recently deployed 20.0.0.306 both Plugin and ActiveX and like everyone else, ActiveX didn't install properly. After playing around with different solutions we found that simply copying all the contents from the C:\Windows\SysWOW64\Macromed\Flash folder of a working install to one that's broken and register the Flash32_20_0_0_306.ocx file by doing a regsvr32 it worked! So basically I'm just running a batch file like this, deploying via SCCM 2012.

       

      xcopy %~dp0\Flash C:\Windows\SysWOW64\Macromed\Flash /c /y

      regsvr32 C:\Windows\SysWOW64\Macromed\Flash\Flash32_20_0_0_306.ocx

       

      I haven't tried deploying the exe like others have mentioned. That may be an easier solution.

       

      I've also reported the bug to Adobe, feel free to report it as well

       

      Feature Request/Bug Report Form

        • 1. Re: Deployment Failures with SCCM 2012 and Flash Player 20
          jeromiec83223024 Adobe Employee

          I've branched this out to a new thread, as it's more effective to discuss the specifics of your scenario, and not carry forward the old baggage.


          For completeness, this thread was originally a reply to a similar thread from 2014, here:

          Installation issues in corporate environment

           

          I honestly have no idea where that wishlist form goes.  It might eventually get routed to us, but my guess is that it's off in some far-removed customer service team.


          The best way to get a bug report to the Flash Runtime engineering team is by filing a bug here:

          http://bugbase.adobe.com/

           

          That said, a copy of the installation logs on a failing machine would be really informative.

          • 2. Re: Deployment Failures with SCCM 2012 and Flash Player 20
            Tim_Menke Level 1

            We're having the same problem with the recently released 23.0.0.185

             

            SCCM claims that it has been successfully installed.  Programs and Features claims that it is installed, but there is no plugin to be found.

             

            For us, it happened for both ActiveX and Plugin.  One coworker of mine claims he's heard of a problem with this and that it has to do with Group Policy installation.   We used to use Group Policy to deploy flash to our users, but a couple months ago we switched to SCCM and the claim is that even though the Group Policy isn't applied anymore.  Computers that have previously had flash deployed via GP may have this glitch, but computers that have never had the GP applied install successfully.    I haven't been able to investigate this more yet.