3 Replies Latest reply on Jul 10, 2016 10:36 AM by craigwinslow

    Mask Problem, AGM internal: Out of bounds

    Luke McPake

      Hi I have a masking problem, I’m drawing and keyframing very simple masks onto .mp4 footage from a C100 and I get this error:

       

      ‘AGM Internal: Out of Bounds ( 83 :: 2 )’

       

      Screen Shot 2016-02-25 at 4.11.16 pm.png

       

      Followed by:

       

      ‘Unknown Exception’

       

      Screen Shot 2016-02-25 at 4.11.23 pm.png

       

      Attempted trouble-shooting I have already tried:

       

      - opened the project on a different system running same version of AE and latest OS (problem persists)

      - Have rendered C100 footage out as a tiff sequence and attempted to mask that (problem persists)

      - Tried rebooting (problem persists)

       

       

      After Effects Version:

       

      13.7.0.124 (up to date)

       

      System:

       

      MacBook Pro (Retina, 15 inch, Early 2013)

      2.7GHz Intel Core i7

      16GB 1600Mhz DDR3

      NVIDIA GeForce GT 650M 1024 MB

       

      Some visual context:

       

      Screen Shot 2016-02-25 at 4.08.00 pm.png

        • 1. Re: Mask Problem, AGM internal: Out of bounds
          chriss84897163

          Hey there - ran into the same problem here. I was working on a project with multiple masks varying colors on a lizard. I noticed that I only got that error when I scrubbed my playhead to 31:08. And it turns out that one of those keyframes that followed 31:08 was causing it for some reason. When I deleted the remaining keyframes that followed when I got that error message, the message never came back.

           


          Only downside is that you have to re-keyframe your mask but no more hair-pulling over that error message!
          Hopefully this helps!

          • 2. Re: Mask Problem, AGM internal: Out of bounds
            BuzzCutsMultimedia Level 1

            I realize this is an old thread but I've been having this issue A LOT with complex manual masking/rotoscoping in 2015.3 cc. I have no idea what the underlying issue is or a permanent solution, but I have discovered a few workarounds.

             

            • It especially seems to happen on masks with an expansion besides 0, and especially on masks with variable expansion and feather. First thing, try resetting these to 0 and see if it persists.

             

            • Instead of losing all your keyframes, you may find that if you set the dysfunctional mask to 'none' and then copy the keyframes onto a new (identical) mask, you may avoid having to start from scratch.

             

            • If the error message pops up so persistently that you cannot save your work or exit the program, try hitting 'Return' on your keyboard repeatedly while also spamming Edit until you can get into Purge > All Memory and Disk Cache. If you can purge, then you'll be able to save immediately after (the errors will return as soon as you ram preview).

             

            • I notice when this issue occurs, there's also sometimes a strange cropping effect on my footage (almost like an invisible mask), and if I try to scale the entire mask, the bounding box on the transform tool is much smaller than the mask itself. My workaround for this is to create a mask over the whole scene and set it to 'Intersect'.

             

            Unfortunately even with these workaround this issue seems to consistently cost me some considerable troubleshooting time several times a week. Anyone else?

            1 person found this helpful
            • 3. Re: Mask Problem, AGM internal: Out of bounds
              craigwinslow

              Getting this exact same error the past few weeks— latest version of AE, it started acting up when I started using expansion, would also error on rendering video.

              Screen Shot 2016-06-30 at 10.48.31 PM.png

               

              Like you suggest, my solution was removing the expansion and everything seems to be working fine again, though the error pops up now and then.

               

              Thanks to this thread for helping me troubleshoot!