3 Replies Latest reply on Feb 29, 2016 6:36 PM by johnrellis

    Photoshop droplets not working (Macintosh, CC 2015.4)

    alanterra Level 1

      My ability to call a droplet in an export script in Lightroom suddenly stopped working. The symptoms are that Lightroom opens the droplet, which launches an app called "Droplet" -- however that app doesn't do anything.

       

      The export script is supposed to work like this: Lightroom exports files and saves them in Folder 1, then Photoshop is supposed to process those files and save them in Folder 2, then I import files in Folder 2 back into Lightroom.

       

      Background: I have 2 droplets that are very similar. I just fired up one and I got an error message from Photoshop that I had a disk problem (“Could not run droplet because of disk error”). It appears that this means that a folder can't be found. I resaved the droplet from Photoshop CC, pointing the Open and Save dialogs to the correct folders, and now I get the above error—an app called "Droplet" is launched, but it appears that Lightroom is not handing it a list of files to process. The droplet works fine if I drop files on it (drop files from Folder 1 on the Droplet, and the processed files are saved in Folder 2).

       

      I get the same behavior (Droplet launching, but no files being processed) if I use another droplet that I saved months ago, so it seems that somehow Lightroom is broken—it seems like Lightroom is not handing any files to the Droplet, so the Droplet just sits there waiting to do something.

       

      As I said in the title, this is Lightroom CC 2015.4, along with 2015.1.2, and Mac OS 10.11.3. I also tried recreating the Droplet using Photoshop CS 6 and got the same behavior, so I don't think that this is a Photoshop problem. I have also tried either keeping the Open and Save steps in the Action, and overriding the Open and Save steps, or turning off the Open and Save steps in the Action. In any case, the Droplet works fine if I drop files on it. It just doesn't work when called from a Lightroom Export script.

       

      Any thoughts? Anyone seeing similar symptoms?

       

      The work-around is obvious--turn off calling the droplet in the Lightroom export script, and drop the files by hand after the export completes. But it would be nice to have my old workflow again.