3 Replies Latest reply on Mar 19, 2016 4:49 AM by Willam van Weelden

    Trouble creating and importing Robohelp Skin

    LynnAIR

      Robohelp 2015, using source control

       

      I can not create a custom skin or import a skin. I also can not even choose a skin from Robohelp's gallery. It appears to work but I can never get a new skin to appear in my Robohelp project.

      This has worked before 2015. Any suggestions?

        • 1. Re: Trouble creating and importing Robohelp Skin
          Willam van Weelden Adobe Community Professional & MVP

          If you look on disk, is there a folder for the skin in the !SkinSubFolder!? If it is there, try removing the CPD.

           

          Can you add a skin to a dummy project or one of the sample projects? It shouldn't be connected to source control, but you never know.

          • 2. Re: Trouble creating and importing Robohelp Skin
            LynnAIR Level 1

            Thank you William for your response. And, sorry for the delay in getting back to you! The folder is there with my new skin (both in Source Control and in my local workspace) and the project believes the skin is there but it does not appear in RoboHelp's Output Setup panel (Skins folder). It is probably a RoboHelp/Source Control issue. Very annoying. Will ignore the issue for now but if you have any other suggestions let me know.

             

            Thank you!

             

            Lynn

            • 3. Re: Trouble creating and importing Robohelp Skin
              Willam van Weelden Adobe Community Professional & MVP

              If the skin is available on disk, but not in the project, the project is out of sync. There are two ways to fix this:

              • Remove the skin from source control and disk and add it again.
              • Update the file rhscreenlayout.apj in notepad.

               

              For the second option, you have to add the following to the APJ file:

               

              <ScreenLayout name="Folder_name_of_screen_layout">

                <ScreenLayoutPages>

                <ScreenLayoutPage default="1" name="Topic.slp" type="1"/>

                </ScreenLayoutPages>

                </ScreenLayout>

               

              Save, trash the CPD and open RoboHelp again.