13 Replies Latest reply on Mar 6, 2016 3:16 PM by Cyndee M

    Importing text always has overrides

    Cyndee M Level 1

      Running latest version of IDCS15 with Win10.

       

      I have a bit of an unusual workflow. I receive large files of MS Word files with all kinds of formatting which needs to be totally removed and reformatted in ID. These files are the content for multiple pages in various ID documents I have setup.

       

      I start off with a "working" documents which has only one paragraph style and no character styles. The one paragraph style is set as the default. I import the text from the Word document with import options set to "remove styles and formatting". I place the text, select it and the one paragraph style always has a plus sign next to it showing there are overrides. I clear the overrides.

       

      Now I need to bring parts of the text from this "working" file into my main ID documents. I cut the text from the "working" file and paste it into the real document. This real document has a paragraph style (along with others) with the identical name and definition of the one in the working file. When I paste the text it again has overrides that need to be cleared. In this case, it is obvious that the override has to do with the Adobe World Ready Composers (which I use because my text contains some Hebrew mixed with the English).

       

      The question is why I should need to be clearing overrides in these 2 cases: 1) when importing the original text from Word and 2) when pasting the Word text into a new ID document with the same style. Clearing the overrides works, but it gets time consuming to have to do it so many times.

       

      This happens over and over again with different sets of files. I have deleted and recreated the files from scratch to be sure nothing I've missed crept in, but no matter what this happens. What should I be looking for?

        • 1. Re: Importing text always has overrides
          Laubender Adobe Community Professional & MVP

          Hi Cyndee,

          did you consider copy/paste from MS Word?
          With the preferences of InDesign set to "Text Only" for pasting text in the "Pasteboard" section.

           

          If some of the formats should travel over like "bold" or "italic" or—you mentioned it—Hebrew, you could try a script by Marc Autret:

          Indiscripts :: RichPaste | Copy and Paste with Minimal Formatting [UPDATE]

           

          Without seeing the original files you are using, I can do no recommendations what to do best in your situation.
          But maybe the script could help.

           

          Uwe

          • 2. Re: Importing text always has overrides
            Willi Adelberger Most Valuable Participant

            Problem is that Word text has properties which are not supported by InDesign but are somehow inherited. It is easy at the end to apply the command to remove overrides. I leave normally Word formatting until the end to see, what was meant in the beginning, but never use any Word formatted style in my document.

            • 3. Re: Importing text always has overrides
              Cyndee M Level 1

              First of all, I said that I import the text from the Word document with import options set to "remove styles and formatting". Wouldn't that get rid of any local formatting in the Word document that would cause a problem. I have no need to see how it was formatted originally as that is irrelevant to what I am doing.

               

              Secondly, I don't think it is the Word file at all since in my working file, as soon as I draw a text box (before importing any text), with the cursor in the empty box, the paragraph style already has a plus sign next to it!

               

              Thirdly, once I eliminate all overrides in the working document, why do they come back in the other file I paste them into?

               

              And I have tried pasting directly from Word with those settings and it does work correctly; I just find the total ID workflow to be more convenient.

               

              One additional point that I neglected to mention above and which might have bearing on the matter is that when I am cutting the text out of the working file and pasting it into the final file I am pasting it into an overridden text frame created on the master page. I do this to be sure the text frame has the correct frame and style attributes (not that it helps).

              • 4. Re: Importing text always has overrides
                Laubender Adobe Community Professional & MVP

                Hi Cyndee,

                if you are pasting text from one InDesign document to another, there is also the option "Paste without Formatting".

                 

                You are saying, that you see overrides in the moment you are drawing out a text frame and begin typing in a new document. Is that correct?
                Then I would close all InDesign documents, go to the Paragraph Style Panel and look for overrides there. ALT+click the "[Basic Paragraph Style]" to get rid of them. Or if that does not work: ALT+SHIFT+click. Maybe even if you see no +sign at the name of the "[Basic Paragraph Style]".

                 

                Then create a new document and start from scratch.
                It could well be that you somehow changed the formatting of the "[None Paragraph Style]", that is the base for the "[Basic Paragraph Style]".

                 

                Uwe

                • 5. Re: Importing text always has overrides
                  Cyndee M Level 1

                  I am already pasting without formatting.

                   

                  Yes, I see the overrides (in the working document that import the text into initially) as soon as I draw a text frame.

                   

                  There are no overrides on the Basic Paragraph style with all documents closed.

                   

                  I created a new document with no styles and as soon as I created a text frame, it had a plus sign next to Basic Paragraph style.

                   

                  Someone I think this is related to my use of Adobe's World Ready Composers. I believe I have it set that everything always uses World Ready, but I wonder if I might have missed a setting some place.

                  • 6. Re: Importing text always has overrides
                    Cyndee M Level 1

                    One additional thing to add -- this happens on 2 different systems (using the same files) when the circumstances are identical.

                    • 7. Re: Importing text always has overrides
                      Cyndee M Level 1

                      I apologize, but I'm bumping this up in the hope someone else might have an idea. Thanks.

                      • 8. Re: Importing text always has overrides
                        Willi Adelberger Most Valuable Participant

                        Is there a there a reason, why you use the World Ready Composer, with text from left to right it should not be used, only when some RTL text come into play o

                        • 9. Re: Importing text always has overrides
                          Laubender Adobe Community Professional & MVP

                          Hi Willi,

                          Cyndee was saying in her first post:

                           

                          … it is obvious that the override has to do with the Adobe World Ready Composers (which I use because my text contains some Hebrew mixed with the English).

                           

                          What is not clear to me, how exactly the Adobe World Ready Composer is used with her paragraph styles and (the usage of)* character styles.

                          Does the Basic Paragraph Style use it? (Maybe not.)

                           

                          Did Cyndee install the Middle East version of InDesign over the English version?

                          I think, without having access to a document we cannot help further.

                           

                          Uwe

                           

                          * EDIT

                          • 10. Re: Importing text always has overrides
                            Cyndee M Level 1

                            It is necessary to use the World Ready Composers for the Hebrew text (whether imported from Word or typed directly in ID) to appear in the right direction. I have my system setup so that all styles use World Ready Composers.

                             

                            Yes, I did install the Hebrew version over the English one -- which seems to be necessary if you need the UI to be in English but need the Hebrew RTL features.

                             

                            I can put the documents into a dropbox, but I don't think there's anything you can see there. I'll get to that shortly.

                            • 11. Re: Importing text always has overrides
                              Cyndee M Level 1

                              Here are links to files in the sequence of the workflow:

                               

                              1) This is the file before I import any text showing that the default paragraph style is selected and there are no character styles selected:

                              https://www.dropbox.com/s/6ykjj60ebq5s0uw/Working1.jpg?dl=0

                               

                              2) This is the same file as soon as I draw a text box (before importing anything or doing anything else) where you can see that there is an override on the default paragraph style:

                              https://www.dropbox.com/s/b7fd8900z0gz5g3/Working2.jpg?dl=0

                               

                              3) This is the same file after placing a Word file (not into an existing text frame; just clicking to create a new one) -- note the pink text is Hebrew which appears correctly once the font for it is changed. Note the override on the paragraph style:

                              https://www.dropbox.com/s/8kjglxt6upln5we/Working3.jpg?dl=0

                               

                              4) This is the same file where I've selected all of the imported text and cleared the override (in preparation of pasting it into the actual file to be used):

                              https://www.dropbox.com/s/8kjglxt6upln5we/Working3.jpg?dl=0

                               

                              5) This is the actual file after pasting in the text (which had no overrides) -- note the override on the paragraph style which must now be cleared again to work with the text:

                              https://www.dropbox.com/s/b3z83qjxkoo9ash/Working4.jpg?dl=0

                               

                              Let me know if there is something else you'd like to see. Thanks for all of your help.

                              • 12. Re: Importing text always has overrides
                                jane-e Adobe Community Professional

                                Can you post a screen shot of your Body Text definition? It's a long shot, but any chance it is based on Basic Paragraph and that Basic Paragraph has a different definition in different documents?

                                 

                                Also, can you hover over the the Body Text with a plus and either read or take a screen shot of exactly what the override is?

                                 

                                ~ Jane Edwards

                                ACI

                                • 13. Re: Importing text always has overrides
                                  Cyndee M Level 1

                                  A screen shot of the paragraph style settings is here:

                                  https://www.dropbox.com/s/rqll4egh6zklgjt/Paragraphy%20Style.jpg?dl=0

                                   

                                  The body text override is: single: flush left, align: flush left

                                   

                                  Thanks.