8 Replies Latest reply on Mar 4, 2016 10:58 AM by jillwoj05

    How do I stop the automatic zoom when moving clips?

    jillwoj05

      Each time I click on a clip in my timeline, it automatically zooms and I can't see where I want to place the clip. How do I stop this? I've tried it with different mouses and it does the same thing so it must be a setting within Premier.