1 Reply Latest reply on Mar 10, 2016 2:12 PM by IsakTen

    "Error when attempting to commit signature" w/ signed document when saving to network location

    winterelegy Level 1

      One of the users here recently started getting the error

       

      "There was an error when attempting to commit this signature.  The document was not saved.  The file may be read-only, or another user may have it open.  Please save the document with a different name or in a different folder."


      when they attempt to sign a document (any document, we tried 10+ different documents) and save it to a network location. Basically when they add a signature to a document it immediately asks to save, and once they pick a network location to save it to, it then attempts to open the file under the new name/location and then it generates that error. So far it seems like it is correctly creating the new file (after seeing the error, if you navigate to that file and open it up it will be signed), but the user signs documents all day and wants to save to various network folders, so getting the error is very annoying and we'd like to figure out what the cause is and how to prevent it. It doesn't seem to do it 100% of the time either; for example if they don't sign anything for a few hours and then try it, it will not generate that error the first time, but if they sign something else and save it than it generates the error. We are on Windows 8.1 64bit and User has full permissions for the network folders they are saving documents to.


      After a whole bunch of stuff I think we MAY have narrowed it down to something with the graphic in the signature. If you choose "Standard text" in the appearance field than it seems to work normally, but once you use an appearance with a graphic than it generates the error. However, when using the same exact signature and graphic files on a different PC (from a user account with the exact same permissions - but not the same user account) it does not generate the error!

       

      We've tried the following things thus far which have NOT fixed the issue:

       

      - Initially user was on Acrobat 11.0.10 Pro. I upgraded them to 11.0.14 and downgraded to 11.0.1

      - Saved file to different network location, different network drive, different file name (saving to desktop WORKS with no error)

      - Turned off "Enabled Enhanced Security" in Preferences

      - Turned off "Verify Signature when the document is opened" option under Preferences>Signature>Verification

      - Created a new signature (many new ones in fact)

      - Created a new appearance for a signature (created several with many different combinations)

      - Copied the signature and graphic for signature file to a network location and loaded the signature from there

      - Saved the graphic from .jpg to .pdf and tried re-creating the signature with the new graphic

      - probably more than I can't remember

       

      Any help or other suggestions on this would be greatly appreciated!