9 Replies Latest reply on Jul 17, 2016 5:32 AM by Toonhaze

    brush tool creates dots (lines not appearing)

    Toonhaze Level 1

      Hi

      I found this topic which explains the problem pretty well:

      Brush tool creates (lagging) dots instead of strokes/lines 15% of the time

       

      How does one fix this annoying problem? I can't possibly sketch in Flash when 20% of my lines are not appearing.

       

      When I sketch in Sketchbook Pro or Toon Boom Harmony there is no problem. However Toon Boom Studio 8 and almost every Flash version (including Animate) has this annoying issue.

       

      Please help

       

       

      My OS: Win7 64bit SP1

      My tablet: I tried both with Intuos2 and Cintiq 21UX (and lots of different drivers)

      My PC: A laptop (Acer Aspire V3-571G) with two graphic cards (Intel and Nvidia). I tried updating the drivers

      I tried many different Wacom settings, I tried playing with compatibility settings, disabling DPI, etc.

        • 1. Re: brush tool creates dots (lines not appearing)
          JosephLabrecque Adobe Community Professional

          Hi. You may not have your stroke value high enough so you are not seeing the lines created? I know that has tripped me up from time to time.

          • 2. Re: brush tool creates dots (lines not appearing)
            Toonhaze Level 1

            Hi. I am not sure what you mean by that.

            I have discovered that if you double-tap quickly with the pen without releasing the pen from the surface (after hitting it the second time) and drawing, while the pen still touches the surface, this problem occurs.

             

            In other words. Even though I deactivate the doubleclick feature in Wacom settings, Flash / Animate still manages to create these small "double-clicks", which cause the lines not to appear.

             

            If "use pressure" is enabled and these "double-clicks" occur (while drawing) the lines don't appear at all.

             

            If "use pressure" is disabled and these "double-clicks" occus, the lines appear as dots.

             

            Sometimes, when this problem occurs (and the pen still touches the surface), it doesn't matter how hard you press down while drawing - nothing get drawn.

            • 3. Re: brush tool creates dots (lines not appearing)
              Toonhaze Level 1

              Can someone please answer this?

              • 4. Re: brush tool creates dots (lines not appearing)
                alexanderv34649542 Level 1

                I have the same issue. I have to keep lifting my pen

                • 5. Re: brush tool creates dots (lines not appearing)
                  Preran Adobe Employee

                  Do you see this issue with the latest update as well? If so, use Feature Request/Bug Report Form to report this bug to the team.

                  • 6. Re: brush tool creates dots (lines not appearing)
                    Toonhaze Level 1

                    Another aspect of this problem is when you click and drag a symbol around. Sometimes (when you drag a symbol) it suddenly goes inside the symbol without you double-clicking intentionally (and then you have to double click outside the symbol to go one step back again).

                     

                    Flash / Animate seems to be generating those micro "double-clicks" whether you are drawing (with Brush Tool) or dragging a Symbol around. This happens very randomly.

                     

                    Can someone with a Wacom tablet please test this? Would be nice to know, if this bug is in the core of Flash / Animate or whether this has something to do with Wacom drivers or with ones PC. 

                    • 7. Re: brush tool creates dots (lines not appearing)
                      Toonhaze Level 1

                      I am still struggling big time to solve this very annoying issue. This problem persists on several Wacom tablets (for me at least - I tried it on Intuos2 and Cintiq 21UX), several operating systems and several Flash versions.

                       

                      AFAIR this problem is also present in Toon Boom Studio 8 so maybe it has something in common with Flash. Both programs are non-OpenGL vector drawing programs AFAIK so maybe they have something in common that creates this exact issue.

                       

                      It might also be a bug inside the core of Flash itself, as it seems to be generating these microscopic double-clicks, when your pen tip touches the surface. And this affects not only your drawing/sketching (with lines not appearing) but also when you are using Transform Tool on objects for rotating, skewing, resizing. Sometimes, when I drag around a symbol, it accidentally ENTERS the symbol as if I double clicked it - but I haven't (deliberately).

                       

                      This problem also affects your workflow when you use your timeline. Sometimes, when you drag within your timeline (using your pen) it just stops (again "double-click" issue).

                       

                      The bottom line - everything in Flash (both GUI elements and the workspace) seems to be affected by this.

                       

                      My assumption is, that when you use your pen, a various number of variables (pressure value, speed, frequency and strength of your strokes, tilt value, etc.) might create these "double clicks" out of thin air.

                       

                      You can try and test it - even with a mouse. Select Brush Tool and double click somewhere in the drawing area - don't let go on the second click - now while holding the mouse button try and draw something... nothing is drawn.

                       

                      If you try this trick in a program like "Gimp", "Alias Sketchbook Pro" or "Toon Boom Harmony 12" - no problem. These programs don't care about double-clicks.

                       

                      Now the question is - what is generating these phantom double-clicks and how can this be helped?

                       

                      When I am watching Youtube tutorials by Jazza or by Happy Harry they seem to do a lot of sketching in Flash and I haven't noticed them having any problems with dissapearing lines. They seem to be using older versions of Flash (CS3, CS5.5, CS6) and Windows 7.

                       

                      I tried:

                       

                      1). Lots of different drivers

                      2). Different combinations of settings in Wacom Tablet Properties

                      3). Windows 7 (64bit) and Windows XP (32 bit)

                      4). Different drawing tablets

                      5). A stationary PC with a single Nvidia graphic card, an old laptop with ATI card, a new laptop with dual GPUs (Nvidia and Intel)

                      6). 100 DPI

                      7). Different Compatibility settings (checkboxes like "Disable display scaling...")

                      8). High contrast theme, Aero theme

                      9). 1280x1024 monitor as Adobe says that this resolution is recommended

                       

                      I am running out of options. But I still have hope. Adobe - please help!

                      • 8. Re: brush tool creates dots (lines not appearing)
                        Preran Adobe Employee

                        You can report this issue to the product team directly using Feature Request/Bug Report Form

                        • 9. Re: brush tool creates dots (lines not appearing)
                          Toonhaze Level 1

                          Hi all

                          (for TL;DR and the solution scroll down)

                           

                          I have had this problem for a very long time and finally found a solution. I have spent a lot of time and energy finding a fix and I now want to share it with everyone else. There is one downside to it, though - you will have no ability to double-click inside Flash (unless you have a suggestion for a workaround), but considering many other things that the solution will fix, it will be worth adapting your new workflow to the one without having to use double-clicks.

                           

                          The problem is that Wacom tablets seem to generate microscopic double-clicks at random times when using a Wacom pen. This is especially annoying when you use programs like Adobe Flash (or Animate) for things like drawing with the Brush tool. This would sometimes result in brush strokes appearing as dots and not lines. And if you have Use Pressure enabled (which most of you do when sketching or rough animating), not even a dot will appear on a failed line - the drawn stroke is not even generated.

                           

                          If you don't believe me that this problem exists in Flash, try going to Control Panel > Mouse and set your Double-click Speed to Slow (press apply). Then go to Flash, select Brush Tool and double click with it (using a pen or mouse) on the drawing area (don't release the mouse/pen on the second click). Now while you're still holding down the mouse/pen (after aforementioned double-click) try moving the mouse/pen. The dot is still there, the cursor is moving and nothing is drawn from the point where the dot is. Then you can test all of the following problems that I describe down below using this double-click trick. The problems affect: drawing, GUI element interraction like Timeline scrubbing, Symbol dragging, Transformation editing of an object.

                           

                          If you don't believe that your Wacom pen is generating these random Double-Clicks go to Control Panel > Mouse. Under the "double-click speed" section there is a little box with a folder that you can use to test your double-clicks on. Now use your Wacom pen to "draw" inside that little box using little strokes. What I mean by that is: imagine that the box with the folder inside it is your drawing space and you just have to draw tiny little lines WITHIN that box. Suddenly you will notice that the folder in that box opens/closes even though you didn't deliberately double-clicked in there. Connect this (Wacom random double-click) problem with aforementioned Flash-Double-Click problem and you can see how many things are affected by it. Maybe your Tablet is fine, but I tried this with 3 different tablets on different operating systems, using different drivers and different Flash versions - the problem seems to be universal.

                           

                          Main problems in Flash when double-clicks are generated (you can test this by provoking the double-clicks yourself):

                           

                          1). (Drawing): Draw something. Select it. Select Free Transform Tool to rotate, scale or skew it. Sometimes you click and drag with your pen on the transform handles and it's just not responding - you have to do it again.

                          2). (GUI Elements): When you drag different windows inside Flash (like Color, Properties, Timeline windows, etc.). Let's say you want to move the Timeline window. A double-click is generated and the Timeline window is collapsed.

                          3). (Timeline scrubbing): Sometimes, scrubbing the timeline also triggers the problem - the scrubbing does not register.

                          4). (Dragging Symbols): Also, when you drag around a Symbol, sometimes with a randomly generated double-click it automatically enters the symbol (as if you would rightclick the Symbol and choose Edit Symbol) - this is so annoying because you then have to exit the symbol to move it and hope it does not happen again.

                          5). (Other Drawing Tools): The problem can also happen when you use Pen Tool and Eraser Tool. And sometimes, when editing a shape of a line by dragging, it generates a double-click and selects everything, instead.

                           

                          In other words - nearly every element of Flash / Animate GUI (graphic user interface) is affected by this annoying bug.

                          This becomes very frustrating in the long run - it was for me at least. Sometimes you just know which line to draw and where to draw it but once you start drawing it, it is not even appearing - pure anti-climax.

                          This problem (the double-click bug) seems to appear around 10-20% of the times according to my testing.

                          I had this issue on Windows XP (32-bit) and Windows 7 (64-bit). Even Windows 8 and Windows 10 didn't seem to solve the problem.

                           

                          TL;DR and SOLUTION: To fix the Wacom Tablet issue in Flash (for when your brush lines are not appearing or the user interface is not responding properly when interacting with it when using your Wacom pen) press Win+R (or go to Start > Run), type "regedit", press OK, go to HKEY_CURRENT_USER > Control Panel > Mouse, rightclick on "DoubleClickSpeed" entry to the right and choose Modify, change the value to "1", press OK, relog or reboot. To get your double click function back, simply change the value of "DoubleClickSpeed" to something higher like "200" (minimum) or "900" (maximum). Alternatively, you can do it by going to Control Panel > Mouse and playing with the slider of the Double-Click speed. Lowest value should be 200 and the highest 900. This is at least true in Windows7. I also tested this in Windows XP.

                           

                          Normally, I use my upper button of my Wacom pen for double-clicks (mostly for entering and exiting symbols) but after setting DoubleClickSpeed to "1" I can't seem use that button for double-clicks. So I found a temporary workaround solution. In Wacom Tablet Properties I assigned this button to Keystroke "Ctrl+E" which is a shortkey for Edit Symbol in Flash. Then in Flash I created a Command for "Exit Edit Mode" and assigned a shortcut "Ctrl+Shift+E". Now I can select a symbol, use my upper button to go inside it, go inside the next nested symbol, etc. And to go back to the main stage, I can hold down Shift and press my upper button (which will trigger "Exit Edit Mode") until I am in the main stage.

                           

                          Conclusion:
                          In the beginning I thought that this problem was Flash-exclusive. But I saw similar behaviour in Toon Boom Studio 8. The same dots were generated sometimes, when drawing. Maybe it is a common problem for some vector drawing applications.

                          After tons of research I tried many different things including going to Wacom Tablet Properties, setting Double Click Distance to "off", Disabling "Windows Ink", disabling lots of things in "Pen and Touch", etc. But nothing helped except this simple Regedit trick.

                           

                          EDIT: I think I just found a fix to solve the double-click issue in Flash and still be able to double-click using the Wacom pen button. The Regedit value of DoubleClickSpeed still has to be set to 1 (and you must remember to reboot or relog to apply changes). Now open Flash / Animate. Then open Control Panel > Mouse and fiddle with the Double-click speed slider (mine is set all the way to the left). DON'T press OK or Apply. Just leave it be. You should be able to draw in Flash and use the interface without problems and STILL be able to double-click stuff for like: renaming layers, entering and exiting symbols, etc. I haven't tested it out properly, but so far it seems to be working without any problems.

                           

                          I hope this helped someone out there fighing the same problems that I have. I am not quite ready to give up Flash, as it is still an excellent program for animations and drawing. Yes, Toon Boom Harmony has some great drawing tools and features that Flash doesn't have, but for many of us who are used to working in Flash and feel quite comfortable in it - well, now you have a fix

                          If you have any other suggestions or fixes (especially regarding this double-click issue), please let us know.

                          1 person found this helpful