1 Reply Latest reply on Apr 2, 2016 9:42 AM by Jan Anne

    Problems dragging photos in Lightroom 6 on Surface Pro 3

    KChicago

      For months, I've been having a devil of a time dragging photos.  The problem occurs in virtually every situation, e.g., dragging photos around within a Lightroom folder to make a custom order, dragging photos from one folder to another, etc.

       

      The normal Windows action of moving your mouse pointer to the middle of a photo, holding down the left mouse button and then immediately dragging it to a different location does not work . What does work if you do it very very carefully and with exactly the right timing is move your mouse pointer to the middle of a photo, hold down the left mouse button, move the mouse a teeny tiny bit so very slowly and pause for a second until a black border appears around the photo, then you can drag it to where you want to put it.

       

      This is really annoying and really slowing down my workflow.

       

      I am running Windows 8.1 and Lightroom 6 on a Microsoft Surface Pro 3 with Intel Core i5-4300U processor, 8GB of memory and 64 bit OS. The problem has consistently manifested in various releases including the new 6.5. I do not have the same problem on my HP desktop computer.

       

      This used to work just fine in previous versions. I searched for previous threads on this and there was a bunch of stuff re selecting the middle of the photo (which I've always done) or deleting your LR preferences which I tried to no avail. I also tried turning on or off graphics acceleration and rebooting which makes no difference.