2 Replies Latest reply on Apr 24, 2006 5:55 AM by natg504

    QT3 Error?

    natg504 Level 1
      I'm trying to create a projector of a director project. I can get it to play correctly in director, but when i open the .exe file i get "This application requires an Xtra (QuickTime 3...) that either does not exist or failed to initialize properly".

      Does anyone know how i could fix this? I didn't create the Director project, so i don't know when or what version it was initially created it.


      THanks,
        • 1. Re: QT3 Error?
          Level 7
          Hi.

          The error message that is appearing is basically saying that the Xtra required to
          interpret the QT media in your movie is not present and so it cannot display the
          QT without it. Fixing this is simple, you just need to include the Xtra with the
          projector.

          Xtras can be included in 2 ways:
          1. Embedded in the projector.
          2. Kept as an external file.

          Since '2' is the most common approach, I'll explain how to do it this way first.
          In the location of the exe, create a folder called 'Xtras'. Then go to the
          Macromedia Director Program Folder on your hard drive and look for a folder called
          Xtras. If you're using MX or below, it will be in the main program folder. If
          you're using MX2004, it will be in a folder called 'Configuration.' Once you find
          this folder, look in the 'Media Element' subfolder, then you'll see a folder
          called 'QT'. So, this may be at:
          C:\Program Files\Macromedia\Director MX 2004\Configuration\Xtras\Media Element\QT
          The files in here need to be copied into the Xtras folder created alongside your
          projector exe.

          I have a tutorial on creating a projector, including setting up the Xtras folder
          at:
          http://www.fbe.unsw.edu.au/learning/director/publishing/projector.asp
          So, look there for more info.

          Option '1' i mentioned, embedding the Xtras in a projector, is also covered in my
          above tut link.

          regards
          Dean

          Director Lecturer / Consultant
          http://www.fbe.unsw.edu.au/learning/director
          http://www.multimediacreative.com.au


          • 2. Re: QT3 Error?
            natg504 Level 1
            I tried option #2 & it worked. Thanks!!