9 Replies Latest reply on Feb 27, 2017 6:51 AM by Mr_mpeg

    Choppy Playback - Use OpenCL instead of Cuda?

    adobedre

      Working with latest Premiere Pro 2015.2 on a 15 inch late-2013 Macbook Pro Retina with a GeForce GT 750M graphics card. When I use CUDA Mercury Acceleration, the full screen playback lately has become choppy. But when I switch to OpenCL or Software-Only, then it's not choppy anymore.


      This is strange.


      On the list of certified graphics card it says GeForce GT 750M is supported for both CUDA and OpenCL.


      my QUESTION: Is the OpenCL acceleration just as powerful as the CUDA one?Would've thought CUDA is better, since it's something Nvidia do themselves?


      Thanks!

        • 1. Re: Choppy Playback - Use OpenCL instead of Cuda?
          ECBowen Most Valuable Participant

          Nvidia GPU's do work better with Cuda than Open CL and normally Cuda works better in Adobe than Open CL. However things are different in OSX since development was done later on both OSX and Open CL. Along with this Apple updates OSX which can change the performance of the GPU acceleration based on the current drivers. My suggestion is see if Nvidia has an updated Nvidia driver for the OSX version you are running. If so update to that driver and check the performance. You may have to wait for an Adobe update or an Nvidia update on OSX to resolve playback performance changes. Most of these involve memory management changes any of those parties might be adjusting or playing with so there are several variables involved.

           

          Eric

          ADK

          • 2. Re: Choppy Playback - Use OpenCL instead of Cuda?
            JFPhoton Level 3

            ....read the following article from last year which may bear directly on your problem....Eric is correct concerning  that it may be driver related AND also settings that YOU can change which disable the laptop from switching to the inferior integrated GPU when it SHOULD be using the NVidid GPU.

             

            Enabling CUDA for Premiere Pro and After Effects in the MacBook Pro Retina

            • 3. Re: Choppy Playback - Use OpenCL instead of Cuda?
              adobedre Level 1

              Thank you both for replying, but unfortunately the problem persists.

               

              I'm on the Nvidia card, not the integrated one (according to gfxCardStatus), Cuda is enabled and the latest driver installed (7.5.26) - and yet it keeps dropping frames.

               

              The funny thing I noticed is that it doesn't drop any frames if I'm NOT in fullscreen mode AND neither when I'm in fullscreen mode on an external monitor (24inch 1080p). Only if I go fullscreen directly on the (retina) macbook screen does it get choppy and frames are dropped.

               

              I've attached some info from each of the render systems (all using the Nvidia card) - no frame drops in Software or OpenCL and a loads on Cuda.Screen Shot 2016-03-26 at 16.33.57.pngScreen Shot 2016-03-26 at 16.32.56.pngScreen Shot 2016-03-26 at 16.31.30.png

              • 4. Re: Choppy Playback - Use OpenCL instead of Cuda?
                JFPhoton Level 3

                I am a Windows guy,but, it still sounds like an issue that Eric pointed to...something with the OS that is not working quite right with the NVidia driver. I have read on this forum in the past about other problems between the Apple OS and PPro as well. After all, it DOES work in one mode. However, CUDA should have BETTER performance.  On my Windows laptop, I have TWO 27" WQHD IPS external displays that  run at 1440p, connected to an HDMI 1.4 port and 1.0 minidisplayport respectively, PLUS the native 1080p screen running on the laptop. All this with no performance differences,or, problems.......the 2560x1440p monitors will even run at 60 fps with no problems. However, the latest NVidia driver that just came out would NOT allow my setup to run normally....the laptop would only work when NO external monitors were connected,so, I had to roll back the driver.

                    I guess you'll have to keep digging.......on a Windows machine you can monitor the real time performance stats of the GPU with the free MSI Afterburner program ,or, similar. You can view the real time GPU clock speed and Memory clock speed and actually can see by the readings if the machine is dropping to the integrated card while in use. I'm not sure how you would do that on a Mac.

                    Hopefully, like Eric said, an Apple OS update,or, newer NVidia driver will correct this problem.  When I first got my machine I was having weird GPU problems like yours until I realized that even though I was "plugged in" to an ac outlet, the DEFAULT POWER SETTINGS were NOT set at "maximum performance". I had to manually reset every power setting for "maximum performance" to prevent the machine dropping down to the integrated GPU.....even when plugged in !!  Of course, you MUST be plugged in when editing ,or, exporting as the laptop will throttle no matter WHAT the power settings are.

                 

                Good Luck !

                • 5. Re: Choppy Playback - Use OpenCL instead of Cuda?
                  adobedre Level 1

                  Thanks very much for that reply!

                   

                  I have configured my Mac - using gfxCardStatus - to always only use the discreet card, so I think I can exclude the error where the integrated card falsely takes over and drops frames.

                   

                  Guess I can only wait and hope for an update from Apple, Nvidia and/or Adobe...

                   

                  Thanks again.

                  • 6. Re: Choppy Playback - Use OpenCL instead of Cuda?
                    ECBowen Most Valuable Participant

                    The external monitor automatically uses the Nvidia GPU. However the Laptop display may use the Intel or Nvidia depending on the whether the application activates the Nvidia GPU instead of the Intel. Nvidia's optimus has had issues in the past working correctly with applications activating the Nvidia instead of the Intel graphics even when you set it with the Nvidia driver. Those options to  set the GPU are available in Windows but OSX does not have the same Nvidia settings panel. You will likely require a driver update to resolve this.

                     

                    Eric

                    ADK

                    • 7. Re: Choppy Playback - Use OpenCL instead of Cuda?
                      adobedre Level 1

                      Thanks, Eric! I'll keep looking out for that driver update... hopefully they still care about the older Macbooks with Nvidia cards after several years of AMD in the newer models.

                      • 8. Re: Choppy Playback - Use OpenCL instead of Cuda?
                        adobedre Level 1

                        Well, it's been months and I've installed Cuda, Premiere and MacOS updates but the problem still remains.

                         

                        Can I really be the only one with those problems?

                         

                        I guess Macs with Nvidia aren't considered much for fixes anymore since it's all AMD for apple now?

                        • 9. Re: Choppy Playback - Use OpenCL instead of Cuda?
                          Mr_mpeg Level 1

                          Im on a desktop mac with a gtx970 and i have the exact same issue. Using openCL now and i can just phantom how much performance i'm losing. I have bootcamp installed and will make a render comparison when i find the time.