3 Replies Latest reply on Mar 20, 2016 12:43 PM by nickynqns

    Why does Lightroom take forever to do anything at all?

    nickynqns Level 1

      Please help. I'm new to Lightroom, but this software is either bloated or stupid.

       

      I'm accustomed to Picasa where if I click something, it happens. If I type something, it happens. With Lightroom I click something, go make a tea, come back, and it's still not done.

       

      Here's a video of nothing happening; mind you this 1 minute video is *after* I already waited ~1 minute for it to do anything at all, and it still doesn't do anything in the time of the video:

      VID_20160318_115657.mp4 - Google Drive

      You can see I'm trying to load a folder with *1* image in it; the tap-tap-tap sound is me hitting the Esc button in the hopes of it killing the 'Loading' process, which it doesn't.

       

      What am I missing?

       

      I have an i7 laptop with 16GB of RAM; my machine is capable, it's only with Lightroom that nothing ever happens, ever.

       

      If I don't resolve this software's functionality in the next week or so I'm going to have to unsubscribe from Adobe products forever; this is my first foray into their CC software suite.

       

      Literally nothing happens. I have to kill the software in Task Manager and re-launch between actions.

       

      What am I missing?