5 Replies Latest reply on Mar 19, 2016 9:27 AM by DadOf6

    Issue with Updated Lightrooom cc

    thunderfromdownunder Level 1

      When trying to open the updated latest version of Lightroom CC I keep getting this error:

      Screenshot_19_03_2016__11_15_PM.jpg

      When I Click hit to repair button I get this

       

      Screenshot_19_03_2016__11_16_PM.jpg

      I have tried this fix by adobe instructions

       

       

      Solutions 

       

          

      Solution 1: Click [Repair to Continue]

       

      Solution 2: Manually change the permissions on three folders and their contents to Read & Write using the File Info dialog.

      Adobe applications need to write to these folders when they open and during use.

      Use this Apple technote: https://support.apple.com/kb/PH21997?locale=en_US&viewlocale=en_US

      to perform the permissions changes on these folders:

      • /Users/[user name]/Library/Preferences/
      • /Users/[user name]/Library/Application Support/Adobe/
      • /Users/[user name]/Library/Caches/Adobe/

      From Apple help doc:

      Apply permissions to all items in a folder or a disk

      1. Select a folder or a disk, then choose File > Get Info.
      2. Click the lock icon to unlock it, then enter an administrator name and password.
      3. Click the Action pop-up menu (gear icon) , then choose “Apply to enclosed items.”

      Note: The user Library file is hidden by default on Mac OS X 10.7 and later. For temporary access to the user Library file, press Option and choose Go > Library in the Finder.

       

      Solution 3: If the above steps does not cure your user folder permission issue, try the following commands in the Terminal app

      1. Type "Terminal" in the Spotlight search box and launch Mac OSX's Terminal app
      2. At the Terminal command prompt, type exactly the following and then hit the enter key (this will remove the Access Control List on the folder and all its subfolders recursively): chmod -RN ~/Library/Preferences/Adobe
      3. Try launch Lightroom to see if it works. If it still does not work, go back to the Terminal command prompt, type exactly the following and then hit the enter key: chmod -RN ~/Library/Caches/Adobe
      4. Try launch Lightroom to see if it works. If it still does not work, go back to the Terminal command prompt, type exactly the following and then hit the enter key: chmod -RN ~/Library/Application\ Support/Adobe

       

      Solution 4: Setup a new admin user account on the machine and run Lightroom from that new account instead.

       

      I have not tried no:4 has anyone got a solution, please

        • 1. Re: Issue with Updated Lightrooom cc
          florio72

          I tried everything, only Solution 4 worked on my Mac Pro El Capitan.

          Still I am very frustrated because when I log in as a new Admin, I have nothing else under that account, it's like a brand new computer.

           

          ADOBE please fix this issue it is really frustrating.

          • 2. Re: Issue with Updated Lightrooom cc
            DadOf6 Level 1

            Same issue.  LR was working before I updated to the latest version this morning.  Updated and now get this message every time.  This would indicate that the issue was created by the upgrade. 

             

            I have done everything except step 4, which is not really a fix for this problem.  That's another indicator that they messed up something during the install of the update.

             

            My permissions are correct.  I've even run permissions repair on my El Capitan volume, and tried running in safe mode.  Nothing works.  Of course, Adobe Support is not available on Saturdays.

             

            Adobe_Info_and_Preferences_Info_and_Adobe_Info.png

            • 3. Re: Issue with Updated Lightrooom cc
              Alfred Pennyworth Level 4

              I saw this interesting article on the bug reporting forum, apparently the update tried to fix a bug and has done so somewhat too forcefully!!

               

              Lightroom 2015.5: Won't start. Ask to change permission of folders, but that doesn't solve. | Photoshop Family Customer …

              • 4. Re: Issue with Updated Lightrooom cc
                DadOf6 Level 1

                Just tried removing and reinstalling LR (via the Uninstall function in CC).  This did not help with this issue either.

                • 5. Re: Issue with Updated Lightrooom cc
                  DadOf6 Level 1

                  Figured this out.  There's another folder containing app info.  You need to add permissions to this and the subfolders.  Not sure why this requires specific user-level permissions now, it did not in the past AFAIK.

                   

                  Note: you will need to ensure the permissions are correct per the previous solution article before you do this (except for step 4 - creating a new admin account.  Don't do that!).  If those aren't correct, and you only do this piece, Lightroom still won't work.

                   

                  1. In Finder, go the menu bar and click Go > Computer (or Shift - Cmd - C).  Then go to your HDD (could be something like Macintosh HD) > Library > Application Support

                  2. Right-click Adobe folder, and select "Get Info".  Or, highlight the Adobe folder and type Cmd-I.

                  3. Authenticate to the folder by clicking the lock icon at the bottom right of the Info window.

                  Adobe_Info.png

                  4. If your user name is not in the Sharing and Permissions list, click the Plus sign at the bottom left of the Info window. 

                  Adobe_Info.png

                  5. Then select your username from the list and hit OK.  (If the Plus sign is grayed-out, you did not authenticate correctly in the previous step.)

                  6. Ensure your user has Read & Write permissions to this folder.  Under Privilege, select Read & Write next to your user name.  (If you just added your user in step 4, your user will only have Read Only access).

                  Fullscreen_3_19_16__12_24_PM.png

                  7. At the bottom of the Info window, click the Gear icon, then click "Apply to Enclosed Items".  You will get a dialog asking if you are sure.  Click OK and it will adjust the permissions accordingly.  You can then close the Info window.

                  Fullscreen_3_19_16__12_25_PM.png

                   

                  You should be able to start Lightroom now. 

                   

                  My guess is that this is a workaround instead of a real fix.  Users don't normally get Read + Write access to the /Library/Application Support folder + subfolders.  But it gets me back into Lightroom for now.