16 Replies Latest reply on Oct 10, 2016 7:41 AM by Just Shoot Me

    missing folders

    jamesc15687197

      With me rather than files it's the folder which it's listing as missing, I just clicked on the folder on the left panel and it reimported the photos but wiped an entire nights editing in LR. I'm editing from numerous external hard drives and it's only just started pulling the missing folder stunt over the last few nights, no changes have been made to warrant this and I've just lost an entire days editing work because of it Any advice re this very much appreciated

       

      When I try to find the file it takes me back to the original unedited RAW in the folder and says "the file is associated with another photo in the catalogue. Each file can only be associated with one photo". I'm not getting the "find missing folder" option which Adobe says I should be getting, I'm instead getting Update Folder Location which I'm doing, in the grid there's two versions of the photos I imported to edit, the unedited RAW original which is available and the previously edited photo which is unavailable. This means that from now on I can have no breaks, as in do a LR edit and import into PS the following day, everything has to be done in one single sitting which is less than ideal or else I'll need to start from scratch again and all the previous editing work is lost

        • 1. Re: missing folders
          Just Shoot Me Adobe Community Professional

          What operating system are you using?

          Do you disconnect and reconnect external drives?

           

          Clicking on a folder in the Folders section of the left hand panel of the Library module will not Re-Import those images. It may Find them but it is not Re-Importing them.

           

          Sounds like your external drives are going to sleep and partially disconnecting from the system.

           

          All the edits for those images should of been stored in either the Catalog file or in a XMP sidecar file depending on what options you have checked or not checked.

           

          Select one of them and go into the Develop module. Do you see any history for that image?

          • 2. Re: missing folders
            jamesc15687197 Level 1

            Win 10 and the external drives are/were disconnected when I went to bed

             

            The editing history is there but the image/folder is still unavailable

             

            Missing folders.jpg

            • 3. Re: missing folders
              Just Shoot Me Adobe Community Professional

              Have you Reconnected them in the same order?

               

              With Windows every time you connect an external drive it can get a different drive letter. Like if you have EXT A connected and it gets drive letter E. Then you disconnect that EXT and connect a different EXT, EXT B. That drive will also get drive letter E. Then you reconnect EXT A and it now gets drive letter F. LR is looking for those images to be at E:\FolderName\ImageName and that drive is now getting drive letter F. The PATH is wrong.

               

              Best thing to do is manually assign drive letters to external drives starting with X, Y or Z and working your way back up the alphabet. You do that with Disk Management.

               

              So check the PATH of that drive for the folders you are missing. I'll bet it has a different drive letter.

               

              You can't view the edits you have done from the Preview file LR created from the real image file. You have to have the real image file for those edits to be Applied.

               

              Reconnect those folders, Update Folder Location, and your edits will show up. They are there in the history, all you need is the real image file.

              • 4. Re: missing folders
                dj_paige Level 9

                If you have reconnected the drive and it's a different letter than Lightroom is expecting, the easiest thing is to change the drive letter back to what Lightroom expects it to be.

                Windows 10: Change a drive letter in disk management

                • 5. Re: missing folders
                  jamesc15687197 Level 1

                  Spend the day out developing rolls of film then shooting more rolls

                   

                  The PC has two USB slots on the front, it names the drives F or G depending on which slot they're plugged into. Rather than letters my EHD's are all named after myself incase they go walkies whilst out with me.

                  I've done the changing letter back to what it'll have been, G from F but still no joy

                   

                  The pc has two drives, a SSD to operate from and a larger hybrid drive for storage, the EHD's are for storing unedited folders and to have edits stored on multiple drives which are kept in multiple locations

                   

                  Thanks for the replies but it looks like a night of redoing all the work I did last night

                  • 6. Re: missing folders
                    dj_paige Level 9

                    So please be specific now.

                     

                    What drive does Lightroom think one of these missing photos is on? When you hold your mouse over the Folder field in the Metadata panel on the right, the full path and drive name of the file will appear. Show us a similar screen capture.

                    2016-03-20 16_57_30-Lightroom.png


                    What drive does your operating system think one of these photos is on? Show us a screen capture.

                    1 person found this helpful
                    • 7. Re: missing folders
                      jamesc15687197 Level 1

                      It's coming up F but this isn't catching when I take a screenshot

                       

                      Screenshot (5).png

                      • 8. Re: missing folders
                        Just Shoot Me Adobe Community Professional

                        jamesc15687197 wrote:

                         

                        Spend the day out developing rolls of film then shooting more rolls

                         

                        The PC has two USB slots on the front, it names the drives F or G depending on which slot they're plugged into. Rather than letters my EHD's are all named after myself incase they go walkies whilst out with me.

                        I've done the changing letter back to what it'll have been, G from F but still no joy

                         

                        The pc has two drives, a SSD to operate from and a larger hybrid drive for storage, the EHD's are for storing unedited folders and to have edits stored on multiple drives which are kept in multiple locations

                         

                        Thanks for the replies but it looks like a night of redoing all the work I did last night

                        It doesn't matter what you Name the drives, that is just a Name. Windows address them with Letters so LR also address them with letter not names.

                         

                        After you changed the drive letter did you restart the system? If not do that now.

                         

                        You don't have to Redo all your work. You have to get LR to see your images. All your work is still in the history and will be applied once you reconnect LR to your images.

                        There are 2 ways to do that.

                        1) Disconnect both drives and restart the system. Connect the drive that is supposed to be the F drive first (it can be connected to either USB port. Windows will give it the first drive letter available no matter what USB port it is plugged into). Then connect the second drive, the one that is supposed to get the letter G. Now LR should see your images on either drive.

                         

                        2) Use the LR feature to "Update Folder Location". You right click on the drive letter and select that option from the pop up menu then point it to the letter the drive is now.

                         

                        Your screen shot mean nothing as you haven't show the parent folder, IE the drive letter at the top of the list.

                        • 9. Re: missing folders
                          jamesc15687197 Level 1

                          Thanks again for replying, I can't do this just now as I'm uploading a large print order of TIFFs from one of the drives so it'll need to be tomorrow and I'll get back but replies from both of you are very much appreciated

                          • 10. Re: missing folders
                            dj_paige Level 9

                            jamesc15687197 wrote:

                             

                            It's coming up F but this isn't catching when I take a screenshot

                             

                            Screenshot (5).png

                            But you need to also confirm that the photos are actually on F: according to our operating system

                             

                            They probably are on a different drive according to your operating system, which is why Lightroom can't find them.

                            • 11. Re: missing folders
                              jamesc15687197 Level 1

                              It's just found them but in a weird way, I just did the search for missing photos like I already had and this time it came up with the edits

                               

                              Going to get back to finish the edit but thank you both for your time and help

                               

                              Edit, I took a very short break during the edit and when I went back LR had gone back to import state rather than grid, I think when the EHD's are going idle it's clicking out of edit

                              • 12. Re: missing folders
                                you&me

                                I have a MAC and am experiencing the same issue of missing folders- cannot figure it out, even after following the tutorials- anyone? anyone?

                                • 13. Re: missing folders
                                  dj_paige Level 9

                                  you&me wrote:

                                   

                                  I have a MAC and am experiencing the same issue of missing folders- cannot figure it out, even after following the tutorials- anyone? anyone?

                                  Can you explain in detail?

                                  • 14. Re: missing folders
                                    Just Shoot Me Adobe Community Professional

                                    you&me wrote:

                                     

                                    I have a MAC and am experiencing the same issue of missing folders- cannot figure it out, even after following the tutorials- anyone? anyone?

                                    Mac's some times, most of the time, take up to 1 minute to see connected external drives. If you are starting your Mac and then immediately opening LR your external drives might not be mounted yet in OS X. So before you open LR Open Finder and make sure the external drive is showing up.

                                    • 15. Re: missing folders
                                      andreasv96013979

                                      Hi all

                                       

                                      I experience the same problem of missing folders in Lightroom as the other posters before.

                                       

                                      I run LR on Windows 7 and my pictures are stored on an external drive, which I always connect using the same character (F:). If I open the standard catalogue, formerly imported folders are often not shown in the library. If this is the case (and that it is often) I close Lightroom and open a backup file which I know is complete.

                                       

                                      I also tried different workarounds like re-importing missing folders. But here LR always told me that these pictures are already in the catalogue but wasn't able to show the history.

                                       

                                      Overall this behavior of LR is really weird and annoying - looks like a real bug to me.

                                       

                                      Any further ideas other than the already mentioned ones?

                                      • 16. Re: missing folders
                                        Just Shoot Me Adobe Community Professional

                                        Please start your own thread and give exact details of the problem you are having. It would also be goo to include screen shots of the LR library module showing the Folders section of the left hand panel.