1 Reply Latest reply on Mar 23, 2016 6:52 AM by simon.macdonald

    Phonegap Build - CLI 6 - Android Build Failure

    diviyahb

      When I use cli-6 in config.xml of PhonegapBuild, android build is failing due to an social media plugin error. Attached the log info.

       

      <preference name="phonegap-version" value="cli-6.0.0" /> 

       

      Followed this blog:

      http://phonegap.com/blog/2016/02/09/phonegap_6_now_on_build/

       

      Error Log:

      :compileDebugJavaWithJavac/project/src/nl/xservices/plugins/SocialSharing.java:19: error: package org.apache.http.util does not exist

      import org.apache.http.util.ByteArrayBuffer;

        ^

      /project/src/nl/xservices/plugins/SocialSharing.java:420: error: cannot find symbol

        ByteArrayBuffer baf = new ByteArrayBuffer(5000);

        ^

        symbol: class ByteArrayBuffer

        location: class SocialSharing

      /project/src/nl/xservices/plugins/SocialSharing.java:420: error: cannot find symbol

        ByteArrayBuffer baf = new ByteArrayBuffer(5000);

        ^

        symbol: class ByteArrayBuffer

        location: class SocialSharing

      Note: Some input files use or override a deprecated API.

      Note: Recompile with -Xlint:deprecation for details.

      3 errors

      FAILED