1 Reply Latest reply on Apr 4, 2016 11:48 AM by fnordware

    AE changes EXR color space

    vkleinmp Level 1

      Using 32 bit AE project with disabled color management.

      Importing linear 16bit/channel EXRs (the standard) into AE CC changes their appearance. Black gets slightly squeezed together, like the lower part of a "S"-curve contrast enhancement onto the the lowest 5% of the blacks.

      Enabling "Preserving RGB (disable color management conversion for this item)" for the footage and using a gamma filter with 2.2 on the layer(s) gives you the right picture again.

      So AE is messing up already linear EXRs in a project with disabled color management until you also disable color management in the footage.

      For me it looks like AE is putting a 709 correction instead of a sRGB onto linear EXRs.

       

      This is bad for normal 3d renders, (blacks gets darker) but if the EXRs are custom CGI channels like Z-Depth or UV or Position pass or Normal pass, the wrong correction mess up your whole compositing.

      I noticed the error while working with UV-renderings, the texture I put onto them in AE got distorted on the UVs for no apparent reason.

       

      We are using AE for a long time for high-end compositing (yes, done right it works very good, I'm a long term Nuke usr myself and it's better, but not in everything) and a lot of UV mapping with the Re:Map plugin, and I am sure a few versions ago this was working.

       

      How the heck do you ever want to compete with professional software like Nuke if you can't get the color basics right Adobe???

      Of cause our Nuke get it right. Nothing wrong with our EXRs. Time to cancel some creative clouds and get more Nuke licenses.

       

      uv2.jpg

        • 1. Re: AE changes EXR color space
          fnordware Level 3

          vkleinmp wrote:

           

          So AE is messing up already linear EXRs in a project with disabled color management until you also disable color management in the footage.

          For me it looks like AE is putting a 709 correction instead of a sRGB onto linear EXRs.

           

          Yep, this is right. Really what you should do is set a project working space (sRGB is a good one) and then click the box to linearize the working space. After you do this the EXRs will no longer get any color operation applied to them and your view will get the required view LUT.

           

          Nuke was made for this linear workflow but AE had a legacy of people working in video space. You have to set that working space to get the linear workflow.