1 Reply Latest reply on Mar 24, 2016 12:58 AM by Nanaky

    Adobe digital editions error that it only works with Mac OS X 10.7 or later

    creationodyssey

      I have Mac OS X 10.6.8 and I have been trying to two days now to figure out why I keep getting the error that 4.5 version and 3.0 version of adobe digital editions are only compatible with Mac OS X 10.7 or later. Is Mac OS X 10.6.8 not consider a later version?