5 Replies Latest reply on Mar 24, 2016 4:19 PM by ryanskihead

    Migrate from phonegap 3.3.0 to cli-5.2.0

    alexandrub24429785

      Hi,

      I made a application in the past for a client, and now he keeps getting messages from google that he needs to update the application for security reasons.

      I changed the config file but when I try to rebuild my application I get the error:

      Error - Some official plugins have to be updated if using PhoneGap >= 4.0.0. Please upgrade the version of any plugins that may include the following file: FileTransfer.java - You can fix this

       

      org.apache.cordova.device   npm     0.2.12  0.2.8  n/a  android,ios,winphone

      org.apache.cordova.file       npm       1.3.1  1.0.1  n/a  android,ios,winphone

      org.apache.cordova.file-transfer   npm  0.4.6   0.4.2  n/a   android,ios,winphone

      org.apache.cordova.media   npm  0.2.13  0.2.8  n/a   android,ios,winphone

       

      These are the plugins I am using and could not make it work.

      Can you please help me?

      EDIT: I believe I need to do some changes if I want the new phonegap to run, can you please tell me what I need to do ? Where I can find the new plugins and is the setup the same as it was? Do i still need only to edit the config.xml file ?