11 Replies Latest reply on Mar 28, 2016 1:55 PM by ryanskihead

    phonegap build fail (maybe android SDK libs changes?)

    piergiorgiop12572091

      I'm using phongap build cli 6.0.0

       

      From yesterday 24/03/2016 the build for my Android app fail, there was any recent changes in android sdk support libraries in phonegap build?

      I build the SAME APP without problem until the day before..... (23/03/2016)

       

      I get the following error:

      Build Date: 2016-03-25 08:24:03 +0000

      Download https://repo1.maven.org/maven2/com/facebook/android/facebook-android-sdk/4.10.1/facebook-a ndroid-sdk-4.10.1.pom

      Download https://repo1.maven.org/maven2/com/parse/bolts/bolts-applinks/1.3.0/bolts-applinks-1.3.0.p om

      Download https://repo1.maven.org/maven2/com/parse/bolts/bolts-tasks/1.3.0/bolts-tasks-1.3.0.pom

       

       

      FAILURE: Build failed with an exception.

       

       

      * What went wrong:

      A problem occurred configuring root project 'project'.

      > Could not resolve all dependencies for configuration ':_debugCompile'.

         > Could not find com.android.support:support-v4:23.2.0.

           Searched in the following locations:

               https://repo1.maven.org/maven2/com/android/support/support-v4/23.2.0/support-v4-23.2.0.pom

               https://repo1.maven.org/maven2/com/android/support/support-v4/23.2.0/support-v4-23.2.0.jar

               file:/android-sdk/extras/android/m2repository/com/android/support/support-v4/23.2.0/suppo rt-v4-23.2.0.pom

               file:/android-sdk/extras/android/m2repository/com/android/support/support-v4/23.2.0/suppo rt-v4-23.2.0.jar

               file:/android-sdk/extras/google/m2repository/com/android/support/support-v4/23.2.0/suppor t-v4-23.2.0.pom

               file:/android-sdk/extras/google/m2repository/com/android/support/support-v4/23.2.0/suppor t-v4-23.2.0.jar

           Required by:

               :project:unspecified > com.android.support:support-v13:23.1.0

         > Could not find com.android.support:support-v4:23.2.0.

           Searched in the following locations:

               https://repo1.maven.org/maven2/com/android/support/support-v4/23.2.0/support-v4-23.2.0.pom

               https://repo1.maven.org/maven2/com/android/support/support-v4/23.2.0/support-v4-23.2.0.jar

               file:/android-sdk/extras/android/m2repository/com/android/support/support-v4/23.2.0/suppo rt-v4-23.2.0.pom

               file:/android-sdk/extras/android/m2repository/com/android/support/support-v4/23.2.0/suppo rt-v4-23.2.0.jar

               file:/android-sdk/extras/google/m2repository/com/android/support/support-v4/23.2.0/suppor t-v4-23.2.0.pom

               file:/android-sdk/extras/google/m2repository/com/android/support/support-v4/23.2.0/suppor t-v4-23.2.0.jar

           Required by:

               :project:unspecified > com.facebook.android:facebook-android-sdk:4.10.1

         > Could not find com.android.support:cardview-v7:23.2.0.

           Searched in the following locations:

               https://repo1.maven.org/maven2/com/android/support/cardview-v7/23.2.0/cardview-v7-23.2.0.p om

               https://repo1.maven.org/maven2/com/android/support/cardview-v7/23.2.0/cardview-v7-23.2.0.j ar

               file:/android-sdk/extras/android/m2repository/com/android/support/cardview-v7/23.2.0/card view-v7-23.2.0.pom

               file:/android-sdk/extras/android/m2repository/com/android/support/cardview-v7/23.2.0/card view-v7-23.2.0.jar

               file:/android-sdk/extras/google/m2repository/com/android/support/cardview-v7/23.2.0/cardv iew-v7-23.2.0.pom

               file:/android-sdk/extras/google/m2repository/com/android/support/cardview-v7/23.2.0/cardv iew-v7-23.2.0.jar

           Required by:

               :project:unspecified > com.facebook.android:facebook-android-sdk:4.10.1

         > Could not find com.android.support:support-v4:23.2.0.

           Searched in the following locations:

               https://repo1.maven.org/maven2/com/android/support/support-v4/23.2.0/support-v4-23.2.0.pom

               https://repo1.maven.org/maven2/com/android/support/support-v4/23.2.0/support-v4-23.2.0.jar

               file:/android-sdk/extras/android/m2repository/com/android/support/support-v4/23.2.0/suppo rt-v4-23.2.0.pom

               file:/android-sdk/extras/android/m2repository/com/android/support/support-v4/23.2.0/suppo rt-v4-23.2.0.jar

               file:/android-sdk/extras/google/m2repository/com/android/support/support-v4/23.2.0/suppor t-v4-23.2.0.pom

               file:/android-sdk/extras/google/m2repository/com/android/support/support-v4/23.2.0/suppor t-v4-23.2.0.jar

           Required by:

               :project:unspecified > com.google.android.gms:play-services-analytics:8.4.0 > com.google.android.gms:play-services-basement:8.4.0

       

       

      * Try:

      Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.

       

       

      BUILD FAILED

       

       

      Total time: 5.785 secs

      undefined