2 Replies Latest reply on Mar 25, 2016 4:44 PM by lennyjones

    Downgrade Lightroom

    lennyjones

      I've downloaded LR 2015.4 but it won't run on my OS. I'm stuck on OSX 10.8.5 for now because of some older audio hardware that I also use.

      How do I get back to LR 2015.2 or 3?

      Is there an older version page?

       

      thanks!

       

      Lenny