1 Reply Latest reply on Jun 11, 2016 12:08 AM by 99jon

    Smart Previews not updating XMP after USB drive reconnected

    superkevkt Level 1

      I'm not sure if this is by design, but I find that XMP sidecar files for images with Smart Previews don't get updated when the original files get reconnected to the computer. I've got LR set up to automatically write changes to XMP files, but I still have to manually trigger the metadata update. I was expecting this to happen automatically. Is there any way to do it? Or is there a better way for me to manage my workflow? If anyone can suggest an improvement to my workflow, I'm open to it. Here's what I do:

       

      1. When I travel, I take my laptop with me. I import my Canon CR2 files to an external USB drive and create Smart Previews so I can work on them without the external drive plugged in.
      2. I have Lightroom set up to write changes to XMP files automatically.
      3. I plug in the USB drive occasionally, expecting the XMP sidecar files to be updated with changes I made to the Smart Previews.
      4. When I get back to the studio, I plug the USB drive into my desktop computer and import everything.
      5. I discover that LR hasn't updated the XMP files so the files are not up to date with what is on my laptop.
      6. I plug the USB drive back into the laptop and manually write XMP files for each of the photos that has changed.
      7. I copy the updated XMP files back to the desktop computer.
      8. I have to manually tell LR to read the metadata for the CR2 files.

       

      This is messy. Is it a bug or is it by design that LR is not automatically synchronizing changes to the XMP files?