1 Reply Latest reply on Mar 29, 2016 11:57 AM by m_vargas

    Adobe Flash Version 21.0.0.197 System Requirements

    jrl54604634

      According to the website, the latest Flash Version 21.0.0.197 requires a 2.33 gig processor and mine is a Pentium 2.11 gig. Do I just stay with the old Firefox flash plugin (Flash 15) which Firefox calls "vulnerable?" Or can I get some intermediate version? Thanks.

        • 1. Re: Adobe Flash Version 21.0.0.197 System Requirements
          m_vargas Adobe Employee

          Hi,

           

          You should definitely upgrade to the latest version from Flash Player 15.  While the system requirements say 2.33 GB processor, Flash Player will still install on your system, however, depending on your Flash Player use you may experience performance issues.  Version 15 is quite old and there have been a number of security vulnerabilities fixed since it's initial release.  Upgrading to the latest version will protect your system against these vulnerabilities, and give you any new features implemented since version 15 was released.

           

          --

          Maria