11 Replies Latest reply on Jun 11, 2009 1:21 PM by sloper911

    Generate au PDF file

    SchSte
      Hi,
      I juste installed the test version of Robohelp 8, and when I generate a printed documentation, the toggle "generate an Adobe PDF" is not active.

      I can export my printed documentation to Word, but not to PDF, does anybody know why?

      Thanks in advance for your answer.

      Stephan
        • 1. Re: Generate au PDF file
          Peter Grainge Adobe Community Professional (Moderator)
          When you installed, there was an option to install a version of Acrobat. Did you install it? Does it appear in your list of printers?

          • 2. Re: Generate au PDF file
            SchSte Level 1
            Thanks Peter, this was the problem.
            Regards
            Stephan
            • 3. Re: Generate au PDF file
              sloper911

              Peter - I'm having exactly the same problem, File > Generate > PDF. where PDF is greyed out - can not click on it.

               

              I have Adobe Acrobat 9 Pro installed and it works fine.

               

              I do not remember seeing the Adobe Acrobat option during installation, is there a way or place to check it?

               

              When you say "does it appear in your list of printers" do you mean from RoboHelp or in your Printers Control Panel?  Adobe PDF is listed in my list of printers in my control panel and I can print to it just fine from other applications.

               

              Any other suggestions? 

               

               

              - my project is a HTML help project

              - I do not use / have MS Word installed (don't know if that effects PDF printing or not)

               

               

              Thanks so much for your help!  SP

              • 4. Re: Generate au PDF file
                Rajdeep Gupta

                Install the Acrobat PDF version when you are installing RoboHelp. Ensure that PDF is located in the printers list. Else, get a printed Word document and then convert it to PDF using the Acrobat.

                 

                Hope it helps!

                • 5. Re: Generate au PDF file
                  sloper911 Level 1

                  Thanks for the reply.  I have re-installed RH8, and chose the option for Adobe Acrobat.  However, during the installation, I get an error message that I already have a 'greater' version of Acrobat installed (I have Acrobat 9 Pro).  I then get an error "1719  Windows Installation Service could not be accessed contact support".  I do have a support ticket in with Adobe and will post any response here.

                   

                  What's odd, is that if I want to print a single page, I can choose PDF as a printer and print the page in PDF format, no problem.  It's Generate PDF that's not working.

                   

                  Thanks again for any suggestions. SP

                  • 6. Re: Generate au PDF file
                    RoboWizard Level 4

                    Hi there

                     

                    Looks like you need to use the other suggestion offered. Generate a Word document first. Then create a PDF using the Word document you ended up with. Open it in Word and choose to create a PDF from there.

                     

                    I think the ability to create PDF by the icon in RoboHelp is sometimes buggy and doesn't work as it should.

                     

                    Cheers... Rick

                     

                     

                    • 7. Re: Generate au PDF file
                      Peter Grainge Adobe Community Professional (Moderator)

                      See http://www.grainge.org/pages/authoring/rh7/using_rh7.htm (Item 33)

                       

                      I see you are using RH8 but I cannot see reregistering a DLL will do any harm.

                       


                      See www.grainge.org for RoboHelp and Authoring tips

                      • 8. Re: Generate au PDF file
                        sloper911 Level 1

                        Thanks for the suggestions.  Still not working, here's what I've done so far...

                         

                        Rajdeep / Rick:  I don't use MS Office, so I don't have Word installed, I use OpenOffice and have for years.  I don't even know where I would get a copy of MS Word if I had to without buying it, which I don't plan on doing.  So, hopefully whatever I work out does not require MS Word.

                         

                        Peter:  I tried to re-register the DLL and get the following "module could not be found" error.  The file is there on my computer in the path:

                        C:\Program Files\Adobe\Acrobat 9.0\PDFMaker\Office

                         

                        So, I'm not sure what to do next.  I do have a service request in to Adobe, but so far no response.

                         

                        As I noted in my earlier post, I can print to PDF just fine if I print one page at a time and select PDF as my printer, but I can not 'Generate' a PDF from the project.

                         

                        Thanks again for any suggestions.   SP

                         

                        library not found error.png

                        • 9. Re: Generate au PDF file
                          sloper911 Level 1

                          Just another note, I did find this post http://forums.adobe.com/thread/107583 suggesting to run the 'repair' from Adobe Acrobat, which I did.  Generate PDF is still not available.

                          • 10. Re: Generate au PDF file
                            Peter Grainge Adobe Community Professional (Moderator)

                            Well of course you cannot generate a PDF. Now that you have told us you do not have Word installed, the reason is obvious. To generate a PDF, a Word document has to be created. If you do not select the Word option, it still gets created so that the PDF can be generated from it. The difference is that with the Word check box ticked, the Word document gets saved, without the box being ticked, the Word file is trashed. Either way though, it has to be created. Without Word being installed, that is a bit tricky.

                             


                            See www.grainge.org for RoboHelp and Authoring tips

                            • 11. Re: Generate au PDF file
                              sloper911 Level 1

                              Okay, thanks for the heads-up Pete.  I spent about 2 hours on the phone with Adobe support today (and told them I don't use Word or have it installed!), they had me uninstall both RH and Acrobat Pro and re-install, and of course it still doesn't work.  what you say makes sense, but it's kind of frustrating to pay $1000 for a piece of software just to find out that you HAVE to have MS Word installed - from another vendor!  Wow, to assume that everyone is going to have Word is a pretty big leap - plus they don't even mention that anywhere in the documentation or the product info - kind of a big deal I would say.

                               

                              I know it's not your issue, just venting.  Thanks for your help.  I'll take this up with Adobe and post any additional info they give.