10 Replies Latest reply on Mar 12, 2017 5:31 PM by cathyd72898221

    E. ACT_NOT_READY.

    PatC217 Level 1

      Each time I attempt to down load a book checked out from library I get the following error message: E.ACT_NOT-READY. My computer is authorized and I down loaded from library as epub but the book shows up as ASCM in documents. What am I doing wrong? What can I do to fix this problem? Appreciate any help. Thanks.

      I am using Mac Book Pro by the way.

        • 1. Re: E. ACT_NOT_READY.
          Nanaky Level 5

          Windows:

           

              Close all applications.

              Choose Start > Run.

              In the Open text box, type regedit and then press Enter. The Registry Editor opens.

              In the left pane of the Registry Editor, locate the following registry key: HKEY_CURRENT_USER\Software\Adobe\Adept

              Select the Adept key.

              Choose File > Export.

              In the Export Registry File dialog box, select Selected Branch under Export Range. Enter a name and location for the backup registry key, and then click Save.

              Right-click the Adept key and choose Delete.

              In the Confirm Key Delete dialog, click OK.

              Close the Registry Editor.

              Open Adobe Digital Editions and reauthorize.

           

          Macintosh:

           

              quit Adobe Digital Editions.

              Navigate to /Users//Library/Application Support/Adobe/Digital Editions and drag the activation.dat file to the trash.

              If you are using 10.7, see https://helpx.adobe.com/x-productkb/global/access-hidden-user-library-files.html

              Open Adobe Digital Editions and reauthorize.

          5 people found this helpful
          • 2. Re: E. ACT_NOT_READY.
            PatC217 Level 1
            1 person found this helpful
            • 3. Re: E. ACT_NOT_READY.
              klausw90782605

              I moved from an old Mac to a newer one. I get the same error, as well as the E_ADEPT_INTERNAL.

              I can't go to /Users//Library/Application Support/Adobe/Digital Editions and drag the activation.dat file to the trash because there is no such file in my Library. I tried to De-authorize Adobe Digital Editions as well which did not work.

              Any ideas?

              • 4. Re: E. ACT_NOT_READY.
                Nanaky Level 5

                To found the hidden Library should used this: Access hidden Mac OS library files

                1 person found this helpful
                • 5. Re: E. ACT_NOT_READY.
                  klausw90782605 Level 1

                  It finally worked. I first reinstalled ADE and then the file "activation.dat" could be made visible and erased. Apart from that I seem to have various "Library" files... I kept a copy of the old user data, big mistake.

                  Thanks anyway.

                  • 6. Re: E. ACT_NOT_READY.
                    klausw90782605 Level 1

                    Thank you, it worked.

                     

                     

                    Best,

                     

                    Klaus

                    • 7. Re: E. ACT_NOT_READY.
                      cathyd72898221 Level 1

                      Can anyone help further? I'm having the same issue, with no help from Adobe. Had ADE installed, no problem. Changed to a new MacBook Pro (similar to my old one). ADE still worked, on all my old books, until I bought a new book that wouldn't download. As the file looked different, and simply wouldn't download, I assumed it was an issue with bookseller. But now I have another one. So I uninstalled ADE, reinstalled ADE 4.5 etc., tried un-authorizing, and re-authorizing, and ADE doesn't recognize my password. Trying to download gives me the E_ACT_NOT_READY error message. I've tried the "view hidden files", and still can't see that activation.dat file to delete. Now I tried deleting every book from ADE. Went to the hard drive folder where the downloaded .epub files are stored, and tried to add one book to the ADE library ... an older book that worked before. Now, it's saying that file was registered to another user! I only have one user, ME, one Adobe ID that works, one password which I did change today ... HELP, please .. anyone ??? MacBook Pro, Yosemite, ADE 4.5 ... at least for now ... Kindles are starting to look like a better option argh!  Thanks in advance.

                      • 8. Re: E. ACT_NOT_READY.
                        cathyd72898221 Level 1

                        Replying to myself in case it helps someone else. I am PERSISTENT, and finally got an Adobe tech to help me Basically this, and that "Internal error message" are related, and the above steps work, with the following caveats for Mac:

                        First off, deauthorize ADE. NOTE: It give you NO indication it actually deauthorized. In fact, if you click on it will tell you it is still authorized, making it look like it didn't like your password. I wasted more time on this ... new passwords etc.; the tech wasn't fazed; apparently they KNOW it won't tell you it deauthorized ... why not tell US??

                        Close ADE. Once that's done, don't bother trying to uncover hidden files for that "invisible" activation.dat file for ADE. It is visible, once you find the correct library; who knew there were so many??? Just go straight to Finder, Go, Go to Folders and type in ~/Library and hit enter. Bingo, the Applications Support Folder, then the Digital Editions folder, the that darn activation.dat file is right there! Delete/drag it to the trash and empty the trash. Do NOT skip that stupid ~ sideways s symbol. I couldn't find it on the keyboard, left it out, went to other library folders everywhere before the tech figured out what I'd done wrong. The ~ (on my keyboard, just under the upper left esc key) takes you to the System Library Files ... Bingo. Now I'm pretty computer savvy, but am not a programmer ... this may be perfectly clear to others, but it tripped me up way too long. As it sounds like others have had similar issues, I thought this might help someone else. ADE 4.5 back in operation!

                        1 person found this helpful
                        • 9. Re: E. ACT_NOT_READY.
                          danielb37986193

                          Thank you SO much!!!

                           

                          I, too, kept having it seem like it didn't recognize my password, and so wouldn't de-authorize, and so I, too, created a new password here on Adobe, etc.

                           

                          Finally coming across your reply to yourself -- I just went ahead and trashed the dat. file and then reopened DE and could authorize! Yay!  Thanks again.

                          • 10. Re: E. ACT_NOT_READY.
                            cathyd72898221 Level 1

                            You're welcome!  I'm delighted my "reply" to myself helped solve your problem. I so wish Adobe would take the responsibility for their program, and write a few troubleshooting "Fact" sheets, listing steps to take from the beginning.

                             

                            Glad I could help