7 Replies Latest reply on Apr 5, 2016 10:25 PM by AndrewMcD

    Lightroom 2015.5: edit in photoshop doesn't appear in Lightroom after saving as psd

    AndrewMcD Level 1

      So, I've been using Lightroom since the first version, I've been using the edit in photoshop feature for ages, and it's always worked perfectly. Until now.

       

      Lightroom CC 2015.5

      Windows 7

       

      Recently reinstalled Windows and all of my apps.

       

      Selected a photo in one of my lightroom catalogs, chose to edit in Photoshop, edited the file, saved as a psd. Normally, the file would be there in my lightroom catalog. No such luck. Tried to manually import the photo. No dice, Lightroom tells me it's already been imported.

       

      So, is there something about psd file support in the current version of Lightroom?

       

      Filters are off.

       

      File was saved with Photoshop CC 2015.1.2 with the maximize compatibility checked.

       

      I dunno. I'm sorta stumped. I guess I could dump all the xmps into the folder and delete from the catalog and reimport, but that seems extreme.

       

      Feeling very much like when iTunes forced me to "locate" all 25,000 songs on my hard drive after an update. Sure, I can delete the catalog and start again, but, really?