14 Replies Latest reply on Nov 20, 2016 12:51 PM by davidmarx

    My Lightroom won't open. It is showing the message - the Lightroom catalog named Lightroom Catalog cannot be opened because it is too new to be used by this version of Lightroom. Would you like to select a different catalog?

    felicityc89006597

      My Lightroom won't open. It is showing the message - the Lightroom catalog named Lightroom Catalog cannot be opened because it is too new to be used by this version of Lightroom. Would you like to select a different catalog?