5 Replies Latest reply on Dec 22, 2008 5:38 AM by Newsgroup_User

    RSS PHP Help...

    person98 Level 1
      Ok, well I am making a PHP rss reader for my website with updating feeds using this website...
      http://rssfeedreader.com/php.html#HTML

      It has worked so far and I have followed the instructions but I get these errors when I try to view the page that views the feeds...


      Warning: main(): URL file-access is disabled in the server configuration in /rssfeeds.php on line 10

      Warning: main( http://rssfeedreader.com/rss3/rss.php?url= http://feeds.appstorefeeds.com/iphoneapps-books&newpage= 1&chead=&atl=&desc=1&owncss=&eleminate=&auth=&dts=&width= 300&max=5&tlen=0&rnd=1&bt=0&bs=None&nmb=&ntb=&naf=&nst=&nwd=0 &nht=0&dlen=100&lstyle=8&lc=grey&bg=White&bc=white&spc=&ims=1&tc=b lack&ts=10&tfont=Verdana,+Arial,+Sans-serif&rf=www.***.com/rssfeeds.php&phpout=1): failed to open stream: no suitable wrapper could be found in /rssfeeds.php on line 10

      Warning: main(): URL file-access is disabled in the server configuration in /rssfeeds.php on line 10

      Warning: main( http://rssfeedreader.com/rss3/rss.php?url= http://feeds.appstorefeeds.com/iphoneapps-books&newpage= 1&chead=&atl=&desc=1&owncss=&eleminate=&auth=&dts=&width= 300&max=5&tlen=0&rnd=1&bt=0&bs=None&nmb=&ntb=&naf=&nst=&nwd=0 &nht=0&dlen=100&lstyle=8&lc=grey&bg=White&bc=white&spc=&ims=1&tc=b lack&ts=10&tfont=Verdana,+Arial,+Sans-serif&rf=www.***.com/rssfeeds.php&phpout=1): failed to open stream: no suitable wrapper could be found in /rssfeeds.php on line 10

      Warning: main(): Failed opening ' http://rssfeedreader.com/rss3/rss.php?url= http://feeds.appstorefeeds.com/iphoneapps-books&newpage= 1&chead=&atl=&desc=1&owncss=&eleminate=&auth=&dts=&width= 300&max=5&tlen=0&rnd=1&bt=0&bs=None&nmb=&ntb=&naf=&nst=&nwd=0 &nht=0&dlen=100&lstyle=8&lc=grey&bg=White&bc=white&spc=&ims=1&tc=b lack&ts=10&tfont=Verdana,+Arial,+Sans-serif&rf=www.***.com/rssfeeds.php&phpout=1' for inclusion (include_path='.:/usr/local/lib/php') in /rssfeeds.php on line 10

      Personal info was kept out..

      Anyways, how can I can I correct these errors?
        • 1. Re: RSS PHP Help...
          person98 Level 1
          Well anyone know the best idea on how to correct this?
          • 2. Re: RSS PHP Help...
            Level 7
            On Mon, 22 Dec 2008 01:42:38 +0000 (UTC), "person98"
            <webforumsuser@macromedia.com> wrote:

            > Warning: main(): URL file-access is disabled in the server configuration in
            >/rssfeeds.php on line 10

            A lot of hosts disable using file system functions on external files. The
            error suggests this is the case in your code and that your code is
            attempting to get the external file using something like the
            file_get_contents() function or using fopen() and fgets() to read the
            content of the RSS file. The solution would be to use the CURL functions
            or direct socket I/O, if that's the case. However, it's impossible to know
            without seeing more of your code.

            Gary
            • 3. RSS PHP Help...
              person98 Level 1
              Ok, what code would you like to see? I have the code for the page to view the feed which is this...

              <!--#include virtual="/rssfeeds.php" -->

              Then I have the code that goes on the PHP script which it would be getting the feed from which is in the attach code part.
              • 4. Re: RSS PHP Help...
                person98 Level 1
                Wow, ok. I hate when I talk to myself on forums but hey, I figured it out!

                In the php.ini file I need to have it say

                allow_url_fopen = on

                That allows it to work perfect.
                • 5. Re: RSS PHP Help...
                  Level 7
                  On Mon, 22 Dec 2008 13:09:47 +0000 (UTC), "person98"
                  <webforumsuser@macromedia.com> wrote:

                  >Wow, ok. I hate when I talk to myself on forums but hey, I figured it out!
                  >
                  >In the php.ini file I need to have it say
                  >
                  >allow_url_fopen = on
                  >
                  >That allows it to work perfect.

                  If you control the server, then that's correct.

                  Gary