21 Replies Latest reply on Apr 24, 2006 9:46 AM by BristowJoe

    getURL not working in IE??

    abeall Level 3
      I can't remember the last time I've been so tired and frusterated of Flash. It's 2am and I just spent the last 2 hours trying to solve this problem:

      getURL("anything at all");

      does nothing at all in IE. No warning, no nothing, just silence. I know the code block is being executed by placing a _root._alpha = 0 the line before it, and it goes. And it works as expected in Mozilla/FireFox. My Mozilla/Firefox is running Flash Player 8, IE is on Flash Player 7.

      And here's the good part: putting a getURL at the beginning of the movie works.

      So does anybody know of a reason why getURL would refuse to work in IE? Ugh.
        • 1. Re: getURL not working in IE??
          Level 7
          "abeall" <webforumsuser@macromedia.com> wrote in message news:e12b5m$fss$1@forums.macromedia.com...
          >I can't remember the last time I've been so tired and frusterated of Flash.
          > It's 2am and I just spent the last 2 hours trying to solve this problem:
          >
          > getURL("anything at all");
          >
          > does nothing at all in IE. No warning, no nothing, just silence. I know the
          > code block is being executed by placing a _root._alpha = 0 the line before it,
          > and it goes. And it works as expected in Mozilla/FireFox. My Mozilla/Firefox is
          > running Flash Player 8, IE is on Flash Player 7.

          Is it the same problem if you publish for version 7?
          tralfaz


          • 2. Re: getURL not working in IE??
            abeall Level 3
            tralfaz -

            Sorry, I forgot to mention that. It's actually being published to Flash6, AS1.0. I have naturally checked, doubled checked, triple checked, Nth checked every single publish spec, but this is so bizzare I'm open to checking yet again.

            It's crazy. It's so specific(getURL works everywhere else in the same movie on the same platform), that I wonder if it might be a Flash 8 compiling bug; it wouldn't be the first I've run into. Basically after two hours [of lost sleep and fruitless effort] last night, here's where I had come to:

            - tested platforms: Mozilla/FireFox FP8, IE FP7, Win XP sp2
            - SWF publish specs: Flash 6, AS1.0, compiled from Flash 8
            - The SWF has perfectly working getURL throughout the _root timeline in all tested platforms
            - The SWF has perfectly working getURL in all timelines tested on Mozilla/FireFox
            - In IE, the SWF would not communicate with getURL from a specific location (_root.suvery_mc.superDump()) even though the code block was clearly executing
            - allowScriptAccess params seemed regardless

            At that point I went to bed. I can't work on it untill this evening, but I'm going to look in depth at exactly what places the getURL successfully works, and what places it fails, and see if I can determine any pattern.

            In case it helps, here's the order of exectution, after the user event that triggers it:

            [all in _root.survey_mc.]
            nextSlide()
            slideTo()
            onEnterFrame()
            superDump()
            getURL()

            As stated several times, the getURL works in Moz/FF w/ FP8, but not IE FP7, while a getURL on the _root works in both.
            • 3. Re: getURL not working in IE??
              kglad Adobe Community Professional & MVP
              what's the onEnterFrame() doing? is it repeatedly calling superDump() and is superDump() repeatedly calling getURL()?
              • 4. Re: getURL not working in IE??
                abeall Level 3
                onEnterFrame is essentially a tween... it fades out some clips, and when it reaches a certain point it does some logic and calls superDump() and deletes onEnterFrame
                • 5. Re: getURL not working in IE??
                  abeall Level 3
                  ^ and yes, I have 1) checked to make sure the onEnterFrame is succesfully deleting itself, 2) the superDump() is being called and executed in full, 3) the line before and after the getURL() is being executed
                  • 6. Re: getURL not working in IE??
                    kglad Adobe Community Professional & MVP
                    post a link to your fla.
                    • 7. Re: getURL not working in IE??
                      abeall Level 3
                      Good call, and that's the issue here. I can't post the original(NDA) so I'm going to have to reproduce it, and I haven't been able to reproduce it - which is what makes me think it's a very specific compiling error. I will try this evening more in depth to replicate it exactly, and if I succeed I will cetainly post a .fla.

                      Thanks for your interest.
                      • 8. Re: getURL not working in IE??
                        kglad Adobe Community Professional & MVP
                        ok
                        • 9. Re: getURL not working in IE??
                          abeall Level 3
                          kglad

                          Here are my latest test files:
                          http://abeall.com/JStest.fla
                          http://abeall.com/JStest.html

                          I carefully deconstructed my movie, and believe I have isolated it to two problems(that were together rendering getURL useless). I'll admit first off that, as you might have guessed, there was some misinterpretation on my part as to what Flash was doing.

                          I said that getURL was not operating at all in IE. This was false. In actuality, it was simply effectively doing nothing because of two problems:

                          1) IE blocks getURL calls to a _blank window.
                          2) IE limits the message size of javascript:alert(message) calls(and my message was too large... a 10+ page form POST array)

                          At other points during testing there were other unrelated problems that were causing no javascript to function at all, or getURL calls blocked by security measures, and I failed to test *every* possible combination untill now to isolate the problems.

                          That said, these are two huge problems with IE I was not aware of(didn't used to be like this?), or I am further doing something wrong to cause them. But IE is definately blocking getURL(url,"_blank") calls, and this is a huge problem for my project, and almost dehibilitating and certainly deterring me from using Flash in the future for most projects that hereto I would have promoted Flash for. Also the limitation on the javascript really worries me, I have that feeling I have no idea what else will fail.

                          So, any advice or insight on these two issues would be highly valued. Thanks.
                          • 10. Re: getURL not working in IE??
                            abeall Level 3
                            Well, it appears that after 3 years of Flash experience I'm still an extremely slow learner. It took me literally 5+ hours to discover what many of you already know:

                            getURL() is blocked by modern browsers(including IE and FF1.5+) if outside of certain interactive events(such onRelease). After I found this out, I did some searches on getURL and issues, and find that there are tons of problems all over the place with browsers and Flash getURL these days. Problems both I'm experiencing during testing and reading about seem very inconsistent(for instance, in one case on(release) getURL is blocked, while onRelease getURL on the same object with same params is not, IE only). I really need to find a good resource that documents this, so I can predict how my Flash will behave for the market.

                            Don't ya just love how technology makes things so much easier? ;-) Still like Flash, just not been a good week. :-)
                            • 11. Re: getURL not working in IE??
                              kglad Adobe Community Professional & MVP
                              that sounds like a pop-up blocker issue. many of use pop-up blockers (and apparently, at least, one of your browsers does, too.
                              • 12. Re: getURL not working in IE??
                                abeall Level 3
                                Yes, apparantly. I just never knew that the built in IE and FF pop-up blocking would block Flash _blank getURL calls.
                                • 13. Re: getURL not working in IE??
                                  kglad Adobe Community Professional & MVP
                                  it's pretty easy to define a for-loop or even setInterval() loop that would cause 100's or even 1000's of pop-ups and crash someone's system. pop-up blockers are a good thing.
                                  • 14. Re: getURL not working in IE??
                                    abeall Level 3
                                    True, but it just really complicates things for Flash, since normally you can just click "allow pop-up" on a regular site, but on a Flash site that restarts the entire site. Still, good to know the limitations now.

                                    If I was creating a pop-up blocker, my solution to the problem with loops/intervals would be to detect "too many" calls in a short period of time and block them all, not blindly block all "_blank" calls. Also it confuses me why some "_blank" calls from user events, such as onPress or onRelease, get blocked. But I don't develop such apps, so I speak out of ignorance.
                                    • 15. Re: getURL not working in IE??
                                      kglad Adobe Community Professional & MVP
                                      yes, i also know little to nothing about how pop-up blockers work. but i keep mine active because i get annoyed when i click on a link and some advertisement/garbage opens up.

                                      and i sure remember visiting some websites would lead to all kinds of pop-ups followed by more pop-ups followed by more pop-ups making it very difficult and mandatory to close down all browser windows.
                                      • 16. Re: getURL not working in IE??
                                        beevyarr
                                        So, did you solve your getURL issue? I'm having many a difficulty with the way my Flash site works withing IE. Different issues between IE on Mac and IE on PC, with of course the most problems with PC IE.

                                        However, my issue is a button within a movieClip that is scripted as so:

                                        on (release) {
                                        getURL(prodID+".pdf", "_blank");
                                        }

                                        with the prodID variable being set through other image selections and the ".pdf" just to help target the right file of course. The buttons do open a blank window, but load nothing.

                                        If you've got your problem resolved, I'd love to hear how.

                                        Thanks.
                                        • 17. Re: getURL not working in IE??
                                          abeall Level 3
                                          Well, my particular problem was that getURL() was being blocked in IE if not in an onRelease event. So I something like this:

                                          on(release){
                                          evaluateLinkage();
                                          }
                                          function evaluateLinkage(){
                                          getURL('whatever','_blank');
                                          }

                                          Would not work, because even though getURL is being called from within a function which is being called in an onRelease, it's not directly in the onRelease so IE blocks it. Lame, but my solution was to just make my code so the getURL was in the onRelease, which broke some of my logic and I had to use some hacks, but it worked.
                                          • 18. Re: getURL not working in IE??
                                            beevyarr Level 1
                                            So in theory:

                                            on (release) {
                                            getURL(prodID+".pdf", "_blank");
                                            }

                                            should work fine?

                                            I'm thinking that my coding throughout is too simple, because loading my movie into IE constantly does wacky f*cked up things that don't happen in any other browser.
                                            • 19. Re: getURL not working in IE??
                                              beevyarr Level 1
                                              OK, maybe they do happen in other browsers, too.
                                              • 20. Re: getURL not working in IE??
                                                abeall Level 3
                                                > So in theory:
                                                >
                                                > on (release) {
                                                > getURL(prodID+".pdf", "_blank");
                                                > }
                                                >
                                                > should work fine?

                                                Yes, that should work. Except that I've heard there are problems with trying to open PDFs. The getURL part should work, though. I've personally not had problems opening a PDF with getURL, but I can't remember the last time I had to do that.
                                                • 21. Re: getURL not working in IE??
                                                  BristowJoe
                                                  I am having the following issue, is my problem related to the above?

                                                  I have this simple code on a button and all seemed to be working well until I cut the movie to CD. From the CD I click on the button and nothing happens. I am not sure what additional information to provide so please ask me for the whatever you may need to assist. Thanks in advance.

                                                  on (release){
                                                  getURL("docs/tm9-2815-257-24.swf","_blank")
                                                  }