16 Replies Latest reply on Apr 14, 2016 6:47 AM by trshaner

    Previews slow to load, load, then disappear. Lightroom CC sluggish/crashes. Help please. OS-X

    David Rayden

      Hello,

       

      All was good until 2015.5, and then LR CC went crazy. It slowed to a crawl, crashed regularly, and refused to show the previews.

      1) Library is on shared NTFS USB, which has been integrity checked and verified to death - it's healthy.

      2) For months I had no problems with using the catalogue/library between desktop (Win 10) and laptop (Macbook Pro Retina.)

      3) The day before the upgrade, I was developing on the Mac without issue.

      4) That night I imported my wife's iPhone 6 picots (>11,000) and the drive became full of partially corrupt iPhone files. I purged all of them.

      5) Uninstalled and reinstalled.

      6) Deleted leftover files in users/library/preferences etc.

      7) Rebuilt the library in Windows 10 - without issues. LR CC tuns fine on that.

      8) Cache size increased.

      9) GPU acceleration off.

      10) Standard size previews set on import.

       

      For days now I have been trying to get LR running with this library on the Mac - but it slows to a crawl, crashes, and won't show previews.

      I tried my backup drive - same issues. So I doubt it;s the drive, and the backup has;t got any iPhone files yet, so this is a red herring, I believe.

      Today, I reinstalled again, deleted all preferences, and LR showed the previews. I even reported in another thread (now deleted, as it added nothing) that I was back up and running; but!

       

      Here's a photo of LR after it was showing all previews fast enough, working apparently fine, and allowing me to develop.

      Note: No previews unless I click on a grey square - they were there before. Also, Memory is high, but CPU low. So it seems nothing is happening in the background that is processor intensive.

      IMG_0946.JPG

      IMG_0947.JPG

      IMG_0951.JPG

       

      Any help would be appreciated, as I've been searching the forums and trying to fix this for a week now.

       

      David.

        • 1. Re: Previews slow to load, load, then disappear. Lightroom CC sluggish/crashes. Help please. OS-X
          Akash Sharma Adobe Employee

          Hi David,

           

          Please refer How do I change my monitor profile to check whether it’s corrupted? and calibrate to Gamma 2.2 color profile.

          Then restart your computer and let us know if that helps.

           

          Regards,

          Akash

          • 2. Re: Previews slow to load, load, then disappear. Lightroom CC sluggish/crashes. Help please. OS-X
            David Rayden Level 1

            Hi Akash,

             

            Thank you for looking at this for me.

             

            I did as you asked, but there is no difference, other than my colours are darker. I attach the latest pictures. Let me remind you:

            This afternoon, I thought the problem was solved as the previews all came in after the last reinstall and deletion of previous settings.

            However, after one edit, I went back to the library and the previews were all gone - just grey boxes.

            Now, as you can see, if I "develop", the picture appears, I can edit and save, but note the preview thumbnail(s) in the lower strip never appear - yet, when I go back to library, that *one* thumbnail is visible!

             

            If I go back to another directory and return, ore restart Lightroom, the same thumbnail is great again.

             

            So, the questions is: What could cause the thumbnails to all be present and make me a happy man, and then, in the same session, all disappear and never come back?

            IMG_0960.JPG

            IMG_0961.JPG

             

            Lightroom is slowing to a crawl on this mac since 2015.5 and this problem seems to not go away - even after a reinstall.

             

            I have added no new software or hardware.

             

            David.

            • 3. Re: Previews slow to load, load, then disappear. Lightroom CC sluggish/crashes. Help please. OS-X
              Akash Sharma Adobe Employee
              What could cause the thumbnails to all be present and make me a happy man, and then, in the same session, all disappear and never come back?

              This is a very common issue with computers having a non calibrated monitors.

              Please calibrate your monitor following the link.

              Also Uncheck "Use graphics Processor" in Lightroom>>Preferences>>Performance

               

              ~Akash

              • 4. Re: Previews slow to load, load, then disappear. Lightroom CC sluggish/crashes. Help please. OS-X
                David Rayden Level 1

                Hi Akash,

                 

                I noted above that I followed the instructions, but the result is the same and the photos in my post above are after the calibration and reboot.

                 

                I'm using a Macbook Pro Retina 13" 2014 and everything was fine before last week.

                 

                Any other ideas?

                 

                David.

                • 6. Re: Previews slow to load, load, then disappear. Lightroom CC sluggish/crashes. Help please. OS-X
                  David Rayden Level 1

                  I purged the caches, deleted the files, and still....Crash report link to Google Docs: https://docs.google.com/document/d/1nJgsqkAMEQIehJTe-VCu4dtGp7j_riE-mNUELl-Uogk/edit?usp=s haring

                   

                  A picture speaks a thousand words, a video maybe more.

                  [EDIT] I should mention that I can run Photoshop, Office, even my VM Windows 7 side-by-side, and any other intensive use - and nothing else gives me problems.

                  I should also mention that the first time I uninstalled via the CC app, it said Lightroom needed to be closed, yet it was and it wasn't showing as a task with option+command+escape - I had to force reboot as the Mac wouldn't shut down. Still now, when Lightroom crashes, I have to face shutdown the mac as it won;t shut down, restart, or allow me to eject the disk as (I guess) Lightroom is still hanging in there, and then "repair" the drive in Windows. If I don't force shutdown because Lightroom crashed (i.e. normal quit) - I can eject the drive and it works without issues in Windows 10.

                   

                  Here you can see how slow, and that I have to click on a thumbnail to show it.

                   

                  The HDD activates if I click on a thumbnail, or develop, but otherwise nothing - so Lightroom either thinks it has nothing to do or....??

                   

                   

                  Any more ideas?

                   

                  David.

                  • 7. Re: Previews slow to load, load, then disappear. Lightroom CC sluggish/crashes. Help please. OS-X
                    trshaner Adobe Community Professional & MVP

                    David Rayden wrote:

                     

                    Hello,

                     

                    All was good until 2015.5, and then LR CC went crazy. It slowed to a crawl, crashed regularly, and refused to show the previews.

                    1) Library is on shared NTFS USB, which has been integrity checked and verified to death - it's healthy.

                    2) For months I had no problems with using the catalogue/library between desktop (Win 10) and laptop (Macbook Pro Retina.)

                    3) The day before the upgrade, I was developing on the Mac without issue.

                    An NTFS formatted drive cannot be written to on a Mac system. However, you can use the drive on both a Mac & PC with exFAT formating. See this article:

                     

                    How to Format a Hard Drive For Both Windows and Mac

                    • 8. Re: Previews slow to load, load, then disappear. Lightroom CC sluggish/crashes. Help please. OS-X
                      David Rayden Level 1

                      Hello again,

                       

                      Thanks for trying to help, but yes it can. I use, and have used for a long while, Paragon NTFS for Mac, and can read/write and generally use the NTFS media without issues. Just before the upgrade, I spent a whole day developing >300 photos. They are all still there, with the sidecar files, and they and their adjustments load into Lightroom. It's just sluggish and I have no thumbnails etc.

                       

                      I've been over to their forums and contacted support. I can export jpgs to any folder on this drive without issues. The files copy over, in large numbers, and are all good.

                       

                      Thanks for the idea, though, as it could be a problem if I was new to Mac with no NTFS drivers.

                       

                      David.

                      • 9. Re: Previews slow to load, load, then disappear. Lightroom CC sluggish/crashes. Help please. OS-X
                        David Rayden Level 1

                        Here's Windows 10 with the same catalogue and files loaded from the same disk.

                         

                        Windows 10 Lightroom CC is loading them very fast, whereas the Mac Lightroom CC version (which used to since day 1) now cannot!

                         

                        I apologise for the (somehow ironic) finger/thumb in the video, but it's 01:30 and I am frustrated beyond belief that what was a working workflow has stopped in its tracks, and even a complete reinstall, catalogue rebuild, with new preferences can't fix it! If I have time, I'll try the roll-back, but that, surely, can;t be the answer as there's no guarantee of a fix with the next update if the problem is not diagnosed!

                         

                        David.

                        • 10. Re: Previews slow to load, load, then disappear. Lightroom CC sluggish/crashes. Help please. OS-X
                          trshaner Adobe Community Professional & MVP

                          David Rayden wrote:

                          I use, and have used for a long while, Paragon NTFS for Mac, and can read/write and generally use the NTFS media without issues.

                          OK, I now remember that from your post with the iPhone pictures issue.

                           

                          Before diving in and doing in-depth troubleshooting let's determine if rolling back to LR CC 2015.4 fixes the issue. Follow the instructions at this post:

                           

                          Re: Lightroom CC 2015.* (last: 2015.5) regularly crashes on OS X 10.11

                          • 11. Re: Previews slow to load, load, then disappear. Lightroom CC sluggish/crashes. Help please. OS-X
                            trshaner Adobe Community Professional & MVP

                            The slow thumbnail updates may also be caused by having the Metadata panel set to 'EXIF + IPTC.' Try changing it to 'Default' or 'Minimal' as below:

                             

                            • 12. Re: Previews slow to load, load, then disappear. Lightroom CC sluggish/crashes. Help please. OS-X
                              David Rayden Level 1

                              Hi again,

                               

                              I was falling asleep last night and something occurred to me about the Mac behaving well after I deleted the preview and preferences folder with the old catalogue. I have my best ideas as I fall asleep, which is why I always keep a notepad by my bed. Unfortunately, that wouldn't do as I couldn't sleep, so got up and began testing my theory.

                               

                              I may be on to something - Occam's razor - I'll update if successful with the results. I don't want to go half-cocked with a feeling of success like last time.

                               

                              David.

                              • 13. Re: Previews slow to load, load, then disappear. Lightroom CC sluggish/crashes. Help please. OS-X
                                David Rayden Level 1

                                So, to recap:

                                I plugged in my wife's iPhone to import >11,000 pictures and videos.

                                I had problems with unreadable files and other issues - see here: https://forums.adobe.com/message/8652483#8652483

                                I upgraded to 2015.5 hoping to fix the issue.

                                I posted here about the import problems after the upgrade.

                                 

                                I appear to have made a logical error: post hoc fallacy (Wikipedia is my friend.) - assuming that it was the upgrade that was the issue with Lightroom stalling, as I had cleaned all bad files from the disk, and it worked in Windows 10.

                                The solution:

                                1) Nobody else was reporting quite the same problem, and a complete uninstall and reinstall, and wiping all preferences, didn't fix the issue - ergo it is probably (But not definitely) local to me and not Lightroom.

                                2) The NTFS driver from Paragon was similarly not showing issues like this in the forum, and a complete uninstall and reinstall, and wiping all preferences, didn't fix the issue ergo it is probably (But not definitely) local to me and and not the NTFS driver.

                                3) I had created a new catalogue and this worked on the PC flawlessly - ergo it was not the catalogue.

                                4) Various and numerous tests confirmed the HDD was working well - ergo it was not the WD Elements hard drive.

                                 

                                This left me wondering, what about the cleaning of the files after that failed import from the iPhone? It worked on Windows 10, but is that enough to say they're problem free?

                                 

                                Thankfully, I have a double backup, so I reformatted the HDD (To ExFAT this time - but this, I am sure, is not the issue as the backups are all NTFS*), and restored/copied up from the second backup.

                                 

                                Bingo! The Macbook accepted the files and catalogue and has survived many restarts and reboots today. Problem solved!

                                 

                                After the failed import, there were clearly some files that caused issues with the Mac and were not a problem for Windows. *I am convinced ExFat is not the issue, as I also loaded the NTFS second backup into the Mac and it worked fine! It was the messed up iPhone import leaving some problem files that my purging missed.

                                 

                                It's always a process of elimination. Lesson? Just because a drive's hardware and filesystem checks out, don't assume there are no issues with the files.

                                 

                                I've marked this post as the answer, if that's ok.

                                 

                                Regards, with thanks, as always, for the valuable time people put into assisting on this forum.

                                 

                                David.

                                • 14. Re: Previews slow to load, load, then disappear. Lightroom CC sluggish/crashes. Help please. OS-X
                                  trshaner Adobe Community Professional & MVP

                                  It sounds like formatting the drive to exFAT solves the problem, which would indicate a LR compatibility issue with Paragon NTFS and the iPhone 6 picture files.

                                   

                                  To help others can you tell us specifically what (you think) was causing the issue and what actually resolves it. Thank you!

                                  • 15. Re: Previews slow to load, load, then disappear. Lightroom CC sluggish/crashes. Help please. OS-X
                                    David Rayden Level 1

                                    Hello again trshaner,

                                     

                                    I have confidence in the NTFS drivers as I use them daily and have done for a while - over a year with lightroom. The forums are not lit up with issues, so I suggest there were leftover files from the iPhone import corruption that were still causing problems.

                                     

                                    I blame Lightroom's import module. It is buggy (Until recently videos in the picture folders caused problems) and other people report issues with the flaky nature and 'fussiness' of the import module; particularly many people have issues with iPhone connectivity.

                                     

                                    This all started with the iPhone import. Apple cable, Apple phone, Apple computer, Adobe software. The Macbook was powered by AC and the whole thing left alone to import. After import, I had duplicate, but broken, files, broken files that were not duplicated, and other issues.

                                     

                                    The Synology NAS data files were on there a while before the iPhone import, so I do not suspect them at all. So, to recap, all the issues sorted with the iPhone import and wiping the drive to remove all traces of this made it work.

                                     

                                    Remember - my Backup drive is NTFS and Lightroom on the Mac also reads this data - a clone of the ExFAT data - with no issues. I checked.

                                     

                                    I only removed NTFS as it was a *potential* barrier and an extra layer of *potnetial* problems that I could eradicate. I just re-cheked, and the backup NTFS drive loads and runs as good as the ExFAT.

                                     

                                    Regards,

                                     

                                    David.

                                    • 16. Re: Previews slow to load, load, then disappear. Lightroom CC sluggish/crashes. Help please. OS-X
                                      trshaner Adobe Community Professional & MVP

                                      David Rayden wrote:

                                      I blame Lightroom's import module. It is buggy (Until recently videos in the picture folders caused problems) and other people report issues with the flaky nature and 'fussiness' of the import module; particularly many people have issues with iPhone connectivity.

                                       

                                      This all started with the iPhone import. Apple cable, Apple phone, Apple computer, Adobe software. The Macbook was powered by AC and the whole thing left alone to import. After import, I had duplicate, but broken, files, broken files that were not duplicated, and other issues.

                                      I suggest reporting this issue with the LR Import module as a 'Problem' and add the link to this post "for further information."

                                       

                                      Photoshop Family Customer Community