1 Reply Latest reply on Apr 11, 2016 6:37 PM by Rick Gerard

    Why does my imported illustrator files not appear in AE...

    IanPhotoshop

      I was working on a short video project and wanted to animate some graphics I had created in illustrator. I was able to import the files and animate them successfully . An hour after doing so the files do not appear in on my composition when playing through. I thus double-clicked on the file in the project import box and when it opens it just appears black.

       

      Help! lol...

       

      Thanks,

      Ian

      Screen Shot 2016-04-11 at 8.01.21 PM.png

        • 1. Re: Why does my imported illustrator files not appear in AE...
          Rick Gerard Adobe Community Professional & MVP

          Before I get into my questions for you check to make sure you are running the latest version of AE then purge your cache. If that doesn't work save the project and relaunch AE. If that doesn't work, reboot and relaunch.

           

          First question for you, where did the white come from. If you set the comp background color to white then it's going to be black when rendered because the background is still transparent and that will always render black in RGB renders, show up as transparent in RGB + Alpha renders but play back with a black background in all media players. If you want a white background then you must add a white solid or white shape layer at the bottom of your composition. I didn't see any Solids folder in the Project panel and you are not showing all layers so it's a concern. I see the transparency grid is turned on so there are probably pixels from something there but I can't tell whether the white layer is above or below the layers that are visible.

           

          Second question, What are the other modified properties of the layers in question. You have one layer selected but I can only see a mask path. The anchor point of the selected layer is 0.5, 0.5 which tells me that the layer is only one pixel by one pixel if you imported the layer as a comp with retain layer size selected. The layer is selected in the Project Panel but you didn't include enough of the project panel for us to see the layer size. So on the selected layer I have no idea what mode the mask is set to, where the mask is in relation to the image, and since I don't know what size the comp is I can only assume, because the position is 843, 546 that the mask is pretty close to the right spot on the layer. I don't see layer handles so either you have them turned off or the layer so big that the handles are outside the comp panels view.

           

          The first thing I would do to trouble shoot your problem would be to solo layer 2 and see what you can see. The second thing I would do is to select layer 2 and press the U key twice to reveal all modified properties and start turning things off or resetting them until you see something. If that does not locate the problem the next thing I would do is select the layer and choose Edit Original to check that layer in the AI file. If the layer shows up and there's some size to it then something went wrong in AE and you may need to replace the file. If the layer is missing then something fouled up you original AI file.

           

          If none of these suggestions work for you get back to use with more complete workflow description and the modified properties of all layers in question revealed.