1 Reply Latest reply on Apr 12, 2016 7:47 PM by kerrishotts

    Phonegap run android - not a Cordova-based project error message

    reggielamb

      I downloaded node.js, Phonegap, Brackets and Android Studio. I created a project and was able to look at the results in Chrome's development tool. At my command prompt, when I enter "phonegap run android", I get an error message, "Error: Current working directory is not a Cordova-based project". It is not able to compile my program into a .apk file, load the default AVD from the AVD Manager and display it on the AVD. Can someone please assist me? Thank you.

        • 1. Re: Phonegap run android - not a Cordova-based project error message
          kerrishotts Adobe Community Professional

          In order to interact with a PhoneGap project, you need to be located within the project's directory structure. For example, if you've just executed a "phonegap create ..." command, be sure to "cd" into the project you just created before performing additional PG CLI commands.

           

          If you are located within your project, consider posting your project's structure so that we can see if there's any problems with it. If you're on a *nix machine, "tree -L 3" will probably give us enough information.