5 Replies Latest reply on Apr 17, 2006 4:31 AM by Newsgroup_User

    Audio Volume on return from browser

    Level 7
      I have found that when I open a browser from a projector after I close the
      browser window the background music jumps to a loud volume in the projector.
      How can I keep the volume the same level as when the browser window opened?
      thanks,
      Chris


        • 1. Re: Audio Volume on return from browser
          Level 7
          I have not heard of this before, you might examine the soundLevel which
          is the lingo settable system level, to see if th browser has messed with
          it. You have no scripts that adjust the volume?
          • 2. Re: Audio Volume on return from browser
            Level 7
            To begin music I have
            on exitFrame me
            puppetSound 4, member "Muzic"

            sound(4).volume = 120

            Then the default volume slider behavior.
            when I close the browser the volume comes back loud.



            "JB" <lingoguy@sbcglobal.net> wrote in message
            news:lingoguy-238F2C.12573715042006@forums.macromedia.com...
            >I have not heard of this before, you might examine the soundLevel which
            > is the lingo settable system level, to see if th browser has messed with
            > it. You have no scripts that adjust the volume?


            • 3. Re: Audio Volume on return from browser
              Level 7
              I just tested the movie on my laptop and I do not experience the same
              problem Any idea why it would happen on one system and not another (PC)?

              thanks,
              chris

              "Chris J" <joker@renderforge.com> wrote in message
              news:e1rvu3$rqr$1@forums.macromedia.com...
              > To begin music I have
              > on exitFrame me
              > puppetSound 4, member "Muzic"
              >
              > sound(4).volume = 120
              >
              > Then the default volume slider behavior.
              > when I close the browser the volume comes back loud.
              >
              >
              >
              > "JB" <lingoguy@sbcglobal.net> wrote in message
              > news:lingoguy-238F2C.12573715042006@forums.macromedia.com...
              >>I have not heard of this before, you might examine the soundLevel which
              >> is the lingo settable system level, to see if th browser has messed with
              >> it. You have no scripts that adjust the volume?
              >
              >


              • 4. Re: Audio Volume on return from browser
                James Newton, ACP Level 3
                You may be able to use 'on activateApplication()' to detect when the user returns to your projector. You could reset the volume of the sound in this handler.
                • 5. Re: Audio Volume on return from browser
                  Level 7
                  This works. I used:
                  on activateApplication
                  puppetSound 4, member "Muzic"
                  sound(4).volume = 100
                  end

                  Is there a way to instead of set the volume to a fixed setting (100) to on
                  activateApplication set the volume back to where it was when the browser
                  opened. The user may have dragged the slider up to 200 or down to 0 before
                  clicking on the web link. I need a way to check the volume level when the
                  browser link button is clicked and then set it back to that same level.

                  thanks,
                  chris

                  "openspark" <webforumsuser@macromedia.com> wrote in message
                  news:e1ubcb$joo$1@forums.macromedia.com...
                  > You may be able to use 'on activateApplication()' to detect when the user
                  > returns to your projector. You could reset the volume of the sound in
                  > this handler.