2 Replies Latest reply on Jun 30, 2016 3:01 PM by rocky_vega01

    using flash action script 3 just doesn't want to work to link to a url

    frankc94631182

      so I got a file that has a background transparent button that is supposed to link to a url .com and for the life of me (most likely just too tired) I can not see what steps to do to make it the link for the full animated ad

      any help would be great thanks

        • 1. Re: using flash action script 3 just doesn't want to work to link to a url
          Nipun Asthana Adobe Employee

          You can create a Button symbol, Inside the edit mode of button, keep its Up, Over and Down frames as blank and just specify the hit area by drawing a rect in the fourth frame.

          Now Come out on the main timeline, and use the code snippet(in Windows Menu) to add the snippet - Click to go to a Webpage. Set your desired url and Test Movie.

          It should work fine now.

          1 person found this helpful
          • 2. Re: using flash action script 3 just doesn't want to work to link to a url
            rocky_vega01

            I am using Animate and came across the same issue?? I did the button mode as you listed above, but my url is not working? I don't know what Im doing wrong?

             

            • I created the top layer naming it "ClickTag"
            • Drew a rectangle
            • Converted the alpha to 0
            • converted it to symbol - button
            • open action window
            • selected "Code Snippets"
            • selected "ClickGoToWebPage" under Actions
            • Automated message states "instance has to be named Adobe will generate instance"
            • click ok
            • Code now appears on action screen (with url pointed to www.adobe.com)

             

            I didn't change url yet - because I have had so much trouble getting the click to work.......

             

            I save the file

            export to swf

            test movie in browser

             

            animation moves..... swf works..... mouse changes when over the animation.... but when i click...... Nothing happens?

             

            can you please help - I have gone 100 ways truing to figure this out... and reviewed several online references..... nothing seems to work

            please please can you help