3 Replies Latest reply on Apr 19, 2016 12:20 AM by Nanaky

    ADE 4.5.1 crashing and not getting up again

    michaelas20279138

      Hi,

       

      I know computers are strange. I had my share of error codes and problems. But this one stumps me. Maybe someone here can help.

       

      I am using ADE to download my DRM protected ebooks. When I purchased one, I get a link, ADE is my default program. It opens, the book is added, I put it on my ereader and that's it. Until yesterday.

       

      My newest purchases were coming in and I downloaded them one by one. The third one gave an error. Something about the licence. That moment I did not care. Whatever would be wrong, I will deal with it, after the other books are downloaded. But now the weired stuff started: ADE crashed. Well, happends to the best of us. Just starting again....and there are no more books. No bookshelves. Not even the default ones. Everything is GONE! Attached my e-reader, it popped up in ADE, clicked on it...crash! I can repeat that again and again. No books and when I click on the reader, it crashes. And this is the error message I get:

       

      Problemsignatur:

        Problemereignisname:    CLR20r3

        Problemsignatur 01:    DigitalEditions.exe

        Problemsignatur 02:    4.5.1.0

        Problemsignatur 03:    56d017fc

        Problemsignatur 04:    DigitalEditions

        Problemsignatur 05:    4.5.1.0

        Problemsignatur 06:    56d017fc

        Problemsignatur 07:    ecf

        Problemsignatur 08:    19

        Problemsignatur 09:    System.NullReferenceException

        Betriebsystemversion:    6.1.7601.2.1.0.768.3

        Gebietsschema-ID:    1031

        Zusatzinformation 1:    0a9e

        Zusatzinformation 2:    0a9e372d3b4ad19135b953a78882e789

        Zusatzinformation 3:    0a9e

        Zusatzinformation 4:    0a9e372d3b4ad19135b953a78882e789

       

      Sorry, it's in German ;-)

       

      And now the not-so-funny part: Nothing I tried so far can make this go away. I deinstalled and reinstalled ADE (even used 4.5 once to exclude a 4.5.1.-only error), I deauthorized and reauthorized the computer....nothing changes.

       

      I tried to download the books anew, which gave me different results: the first two or three tries ended in nothing, no change. Started the download, ADE starts...no books inside. At the fourth try the books I just downloaded reappeard, but not the older ones. But then there was the licence error again and all was gone.

       

      No I took out my laptop and installed ADE fresh and authorized the computer and....ADE looked good and all the old books were there. NICE!! Until ... one of the new books again produced this darn licence error and killed everything again. Now I have "burned" two computers. ADE is no longer working as intended on those two. I think I will try it again on another one just to get a screen shot of this error message. But that is beside the point, I think.

       

      Why would ADE crash and burn FOREVER just because it got a little complication with an odd book or two? I would expect it to - worst case! - crash once and not add the book in question. Actually I would expect it to just ignore this error, tell me it cannot add this book and let me add the rest, so I can sort out this damaged book with the shop I bought it from. But, no, it encounters an error and not only crashes, but stays dead and cannot be revived.

       

      I changed nothing on the system before this problem occured. One day it worked, the next it doesn't. No point blaming the computer or the OS (Win7 BTW). This is a problem of ADE triggered by a (probably?) faulty ebook with some conflict.

       

      Can anyone help me to get ADE started again? I will remove the bad book and move on to others, but I don't want to start buying computers in bulk just to accomodate ADE every time it finds another book not to its liking. Maybe there is a workaround? Rename this, copy file X to folder Z? Whatever works.

       

      Thanks

      M.