4 Replies Latest reply on Apr 19, 2016 3:09 AM by Spinland

    After Effects CS6 11.0.4.2 on OS X El Capitan. Track Mask feature apparently not available

    Spinland

      Machine is a 2013 Mac Pro.

       

      After duplicating a layer with a video clip, then adding a mask to that new layer, there appears to be no way to have the mask tracked. Right clicking on the mask item presents no track mask selection in the popup menu, and when the Tracker window is opened and the mask is selected the available choices do not change even though in at least one video tutorial they are supposed to.

       

      Is track mask broken? Is there some config change or bug or glitch that needs to be reset or addressed to be able to track masks in this version of AE?

        • 1. Re: After Effects CS6 11.0.4.2 on OS X El Capitan. Track Mask feature apparently not available
          Rick Gerard Adobe Community Professional & MVP

          If you have the modes column visible you should see track matte options. If the switches column is visible you can switch it by pressing F4.

           

          If if the modes column is visible and you do not have the option for a track matte when there is a layer above then you have enabled Ray-traced rendering and you did not read the warning that pops up. A whole bunch of things are not available when using that rendering option.

          • 2. Re: After Effects CS6 11.0.4.2 on OS X El Capitan. Track Mask feature apparently not available
            Spinland Level 1

            Appreciate the response, but it appears the issue is that CS6 does not support this feature even though I took pains to specify that version when I searched for tutorials. Apparently I was served CC tutes instead.

             

            Thanks again!

            • 3. Re: After Effects CS6 11.0.4.2 on OS X El Capitan. Track Mask feature apparently not available
              Rick Gerard Adobe Community Professional & MVP

              The only way that Track Matte is not available is in CS6 is if you have the Ray-traced rendering option selected in the Advanced section of your Composition settings. Track mattes have been a feature in After Effects for about 20 years and the procedure is always the same. Put the layer you want to use as a track matte on layer 1, put the layer you want to mask on layer 2, in the modes panel select Alpha or Inverted Alpha if your layer has an alpha channel (transparency) or Luma or inverted Luma if you image does not have an alpha channel.

               

              That's all there is to it. If you cannot see the Modes column in the timeline, the one with the blend modes then make sure the column is selected in the Column options by right slicing in the columns at the top left of the timeline. You can also experiment with the little icons at the bottom left of the timeline. The second from the right expands both the modes and the switches column. If you do not have the option to create a blend mode or select the layer above your current layer as a track matte then you have Ray-traced rendering turned on. If you can see blend modes and you still don't see the track matte option then you have collapsed the column. Try resetting your workspace.

               

              This is real basic stuff.

              Note the timeline and the icons selected and the visible columns:

              Screen Shot 2016-04-18 at 6.34.22 PM.png

              Note the change in comp settings and the warning:

              Screen Shot 2016-04-18 at 6.34.52 PM.png

              Note the timeline when the layers are changed to 3D:

              Screen Shot 2016-04-18 at 6.35.13 PM.png

              No blend modes, no track matte.

               

              If you still can't get this to work then take a screenshot of your entire comp with the modified properties of all layers that are giving you problems revealed by pressing the U key twice and show us the Advanced tab in your Composition Settings.

              • 4. Re: After Effects CS6 11.0.4.2 on OS X El Capitan. Track Mask feature apparently not available
                Spinland Level 1

                Thank you for your willingness to help, but you appear to be confused as to what I was asking. As I stated in my original question, I was asking about Track Mask, not matte tracking. I get the terms are similar, so let me clarify with this example of one of the tutorials I was referring to (which came up when I was specifically searching for CS6, and I was too knuckleheaded to catch right away that was because the comments section included people griping about CS6 not supporting this feature):

                 

                https://www.youtube.com/watch?v=Ylvg5IOZrQg

                 

                So, to recap: no, Track Mask is not supported in CS6.

                 

                The good news is that the version of Mocha included in CS6 is exactly what I was after so all is well.

                 

                Thanks again for trying.