5 Replies Latest reply on Apr 19, 2016 5:33 AM by Marc Trzepla

    Trapcode Particular Up Vector Override?

    Marc Trzepla Level 1

      I'm using Trapcode Particular to generate some particles from Sprites.  Unfortunately, as the camera rotates along the Z axis the Sprites do not rotate  - they maintain a north-is-up orientation.

       

      I thought I was being clever by tying in the Particle Rotate Z to the negative of the camera Z Rotation, but it's odd - it only works if I'm testing by scrubbing the Camera Rot Z value - the moment I keyframe the Camera Rot Z I lose the "rotate with camera" effect.

       

      I've tried flipping every switch - Layer Emitter Sampling to Particle Birth Time, Current Time and Still and tried Time Sampling for the texture to Current Time, Random Still Frame, etc..  everything in that list.

       

      Am I missing something basic here that will override the up vector of these billboards to get the particles to rotate as you would expect them to (relative to the screen) if the Z axis of the camera were rotating?

       

      Thanks,

       

      Marc

        • 1. Re: Trapcode Particular Up Vector Override?
          Marc Trzepla Level 1

          Of course I left out what could be the most important part - I emit a bunch of particles from a layer emitter (Z size large, creating a 'volume') on frame 1 at velocity 0 and then set my pps to zero, ending up with a cloud of particles not moving.

           

          I would think that if the particles were all emitted at one time on frame 1 then there's no further simulation or re-evaluation with the scene, or in this case, the camera when it moves past, spinning on Z as it does.

          • 2. Re: Trapcode Particular Up Vector Override?
            Mylenium Most Valuable Participant

            There's nothing odd. Particle rotation like many others is a birth attribute defining the initial orientation. Otherwise your setup doesn't make much sense. If you bank the camera, you can just as well rotate the texture in the pre-comp to create the effect. Everything else works as the effect is intended to operate.

             

            Mylenium

            • 3. Re: Trapcode Particular Up Vector Override?
              Marc Trzepla Level 1

              Hmm... I had tried rotating the precomp too and that didn't work, but now I know why - my Sprite is a comp with 50 1-frame images - my particles are set to Random - Still Frame.  The only way I can get your suggestion to work is to set Time Sampling to Current Time, which I can't otherwise all of the particles are the same.   So I was able to get the banking effect but don't have randomly selected Sprites.

               

              Thanks for the suggestion.

               

              Marc

              • 4. Re: Trapcode Particular Up Vector Override?
                Gutter-Fish Level 4

                Could it be that you're using sprites.  The defining feature of sprites is that they always maintain their facing position to the camera regardless of where or what the camera does no?

                • 5. Re: Trapcode Particular Up Vector Override?
                  Marc Trzepla Level 1

                  Thanks - I think we arrived at the same place at the same time.  I switched over to Textured Polygons and once I re-oriented the particles (they were edge on) I had my a) random images b) banking with the camera.  Perfect.

                   

                  But then, like any good game of Whack-A-Mole, I started ending up with particles that pop off when close to the camera.  The dreaded Near Far Vanish.  I have my Near Vanish set to ZERO (and Far Vanish/Start Fade waay off..) but particles disappear further from the camera than you'd expect them to.  In fact, if I toggle back to Sprite - same visibility values - those same particles REAPPEAR and don't disappear until they've passed out of frame, past the camera.

                   

                  Is there a Disable Clipping feature I'm missing?