2 Replies Latest reply on Oct 13, 2016 3:03 PM by Richard_Schwarz

    Lightroom keyword filter bug.

    kyzyls

      I'm currently running Lightroom 6 under Windows 7 and I've suddenly run into a problem where the set of image being displayed does NOT match the currently selected keyword filter.  Restarting Lightroom fixes the problem until I select/deselect keywords for

       

      This is what I've been doing:

       

      - Select a keyword filter using the right arrow to the right of a given keyword (i.e. keyword "Keyword 1").

      - While reviewing this set of photos, I realize a specific photo belongs under a different keyword (i.e. keyword "Keyword 2").

      - I select the specific photo.

      - I select the new keyword ("Keyword 2").

            - Nothing happens to the set of photos that I'm reviewing, which is correct - this photo now contains two keywords.

      - I deselect the old keyword ("Keyword 1")

            - I would expect the photo to disappear because it is no longer in the current keyword set ("Keyword 1").

            - However, the photo remains, with the currently selected keyword in the list being only "Keyword 2".

      - I think the selection+deselection worked, but the currently active keyword filter is dead.

      - Reselecting the keyword filter that SHOULD be active right now does NOT correct the problem either.

      - Selecting a different keyword filter, then reselecting the original keyword filter sometimes works, but not always, PLUS, you lose your place in the list where you were!

       

      I do these steps quite a lot, so I know this 'should' work, and has worked until just yesterday, but now it does not.  Again, restarting Lightroom seems to fix the problem until I perform the above steps once or twice.

       

      Any ideas about what the problem is?  Or how to fix it?

       

      Any suggestions would be greatly appreciated.  I've suddenly lost all confidence in the accuracy and reliability of Lightroom keywording.

       

      Thanks for your time.