6 Replies Latest reply on May 4, 2016 5:26 AM by fsdafs

    How to disable gap filling

    fsdafs

      I am going to stop using Premiere elements if I can't fix this.  It is a disaster.

       

      I have a 2 hour video of a play.  I've been working on this for a couple months now.  It was 10 tracks, with a few different cameras and audio.  I was able to render parts as I put this together without a problem.  But now that I'm done, I've been trying for three weeks to get it to render.  It occasionally completes, but otherwise fails at different percentages from about 60 to 95.  The couple of times it completed I had a mistake -  because of the gap filling I'm asking about. 

       

      I'm trying to clean up the tracks and make sure there are no gaps.  I've gotten it down to 5 pairs of tracks.  But every time I try to shift things around, the program tries to create or remove a "gap" which messes up the rest of the timeline.  It is insane.  There must be a way to disable this setting.  Please tell me I can tell it to stop closing and filling gaps!!?!?!?!?

        • 1. Re: How to disable gap filling
          Steve Grisetti Adobe Community Professional

          It's all a matter of knowing how to control timeline rippling, fs.

           

          What are you doing that causes the program to ripple closed the gap?

           

          And which version of the program are you using? Newer versions of the program will only ripple to fill the gap if it's on the Video 1 track. Other tracks will not fill gaps unless you command the program to.

           

          As for the crash when you try to output your video -- well, that could be a number of different issues including the amount of available free, defragmented space on your hard drive, your operating system and configuration, the version of the program you have and what your project settings are, what model of camcorder you're using and what format of video you're editing, as well as what you're trying to output your video as. So that could take some troubleshooting.

           

          The simple first question is -- are you able to do this output if your movie is only 10 minutes long instead of two hours long? It's usually wise to do your test drive with a short trip rather than jumping right in with a cross-country trip.

          • 2. Re: How to disable gap filling
            fsdafs Level 1

            Thanks for the tips Steve.  I'm using version 14, and Windows 10. 

             

            Regarding the gaps:  I read online that having gaps between the clips can cause rendering to fail.  So I tried to fix all the gaps I could, but in some cases I wanted a short space, and in other cases I was fading one clip to black and then fading the other one in.  I'm not sure if that counts as a problem.  So as a safety measure, I created a black png image to insert across the lowest video track - the entire track.  Indeed - that was video track 1.  When I dragged the image to be an hour long instead of a few seconds, that is when Premiere gap filling did strange things and screwed up my timeline.  Basically I fixed all the damage it did manually.  And I ended up doing this a few times, one project file seemed to have become corrupt, perhaps another time I messed something else up.  I've lost track, I've been working on this for a while.  But the lesson learned - don't use video track 1 for this purpose!!  I also read that holding down the ctrl key will prevent gap filling, I started doing that, not positive if it made a difference. 

             

            Regarding rendering, I've got hundreds of gigs of space free on both the render to drive and the data drive, and I just checked - they aren't fragmented.  And yes - I've rendered shorter clips successfully I think every time.  It is only when I do a full length mpeg or DVD that it fails regularly.  Even then, it has succeeded two or three times - but unfortunately those images had other problems with the video.  It also only succeeds with a blue ray H.264 file sometimes.  And as you described, there are many other possible variables.  I'm trying again.  And will try again and again as needed.  Since the failures seem random - it fails at different percentages and sometimes succeeds - I'll just keep running it perhaps with minor tweaks to the project. 

             

            I've never made a project nearly this long or complicated.  I hope to writeup what I've learned.  And as I get better at this I think I'll be able to be a bit more systematic.  I was a bit messy with my timeline, partially because I didn't want to mess it up by accident. 

             

            One curious lesson - don't use two files with the same file name in different folders or they may be mixed up by Premiere.  Premiere was playing sound from one file and video from the other! 

            • 3. Re: How to disable gap filling
              Steve Grisetti Adobe Community Professional

              I think you may be overly complicating things by basing early decisions on stuff you found on the internet. It needn't be that complicated. (That's why I wrote my books, on Amazon, and created my course, on lynda.com. To give simple guidance.)

               

              There should not be a gap with no video on your timeline. That's true. But you needn't do anything as drastic as run a background still the whole length of the timeline on Video 1 to prevent it! All you have to do is make sure that any black in your timeline is actually some sort of black of zero-opacity video and not an empty spot. It doesn't have to be on Video 1. Just somewhere on your timeline there must be something. But using drastic measures may do more harm than good.

               

              Meantime, have you been able to output a simple 5 or 10 minute video with some basic footage? As I say, before we react like the entire program or your entire system has gone corrupt, it might be a good idea to see if things are working on a basic level. Then we can track down what's up with the larger project.

              • 4. Re: How to disable gap filling
                fsdafs Level 1

                As I've written in both posts, I am able to render smaller parts of the video consistently.  I think 100% of the time, but I'm not sure.  Note that when I've rendered parts it was rarely over 10 minutes.  I also have generated previews for the entire timeline. 

                 

                I got the full render of the blu ray on I think Sat night, and the full render of the DVD on Sunday evening.  For DVD, I literally tried to render the same project about 5 times during the day, each time it failed at a different percentage until the last one it finished.  BUT, there is another problem with the output: the sound for one section is incorrect.  I believe that the program filled a gap because of my work to condense timelines from 10 to 5, or because of the the black background I put in.  Or perhaps I just made a mistake and extended a sound track where I shouldn't have. I had previewed the entire output in an earlier version and this problem wasn't there.  And I had tested the blu ray output from Sat night prior to running the DVD render, but didn't find the sound problem which only impacts a few minutes out of 120.  When I tested the DVD render I found it - and it impacts both.  So I have to fix the problem and then re-render both.

                 

                I used Premiere 7 a bit back in about 2008 and wasn't happy with it then.  Used Vegas happily since then.  And I switched to Premiere because Vegas can't handle 4k video very well.  Well, after this project I'm not going to use Premiere anymore.  I'm an unhappy customer.  I will find a different product.

                • 5. Re: How to disable gap filling
                  Steve Grisetti Adobe Community Professional

                  Can you output your video project using Export & Share/Devices/Computer/1920x1080 using the M2T format?

                   

                  If you can, use the M2T file and start a new project. Drop in onto your timeline and add menus to it. You should have no problems outputting a DVD from it.

                  • 6. Re: How to disable gap filling
                    fsdafs Level 1

                    SOLUTION!!!

                     

                    So, for my original question - it looks like Steve has the answer.  I didn't test it, but I'll take his word that only when moving things in track Video 1 is gap filling applied.  Also, when I used the ctrl key while moving / expanding clips I didn't witness any gap filling.  So, still hope it will be a on/off switch in preferences, but I may be able to deal with it. 

                     

                    But the root cause of me getting into trouble was rendering problems.  I was shuffling my timeline around to fix any gaps, which led to the frustration from auto-gap filling feature.  But it looks like I've fixed my render problems.  I've rendered a full length DVD, blu ray and mp4 h.264 file without problems.  It looks like it was duplicate file names:

                     

                    I recorded a performance on two nights.  I saved video from each night into separate folders.  It looks like on import Windows re-numbered the files.  So each folder had the same filenames.  I assembled the video using files from each day/folder - either based on the better performance, or the better audio/video quality.  My timeline basically became corrupt - Premiere elements would play video from one file but audio from the same filename in the other folder.  I thought I had fixed this a week ago, by renaming files which are _used_ from folder B.  But I wasn't thinking - even if the file is only used from folder A, the problem remained.  So yesterday I renamed ALL the files in one of the folders, I just added a letter to the filename to keep it simple.  And one by one I instructed Premiere on the new filenames.  

                     

                    After that, I did the three successful renders in a row. 

                     

                    Thank heavens, this was driving me crazy.  I had put a lot of effort into this video, and was about to miss my deadline of this Friday.

                     

                    Thanks for your help Steve!!