1 Reply Latest reply on May 4, 2016 11:58 AM by dj_paige

    how to buy

    destinys_angel15

      how do i just upgrade lightroom to a compatible with nikon d600 and d300 and also d800.  I dont want to be on icloud, i just want to be able to upgrade my lightroom from 3.6 to something compatible

      pelae elp!