6 Replies Latest reply on Jul 13, 2009 3:49 PM by marclijour

    AIR application installer not working on Linux x86-64

    worosen
      I've installed AIR on my i586 Linux system and got an application installed w/o any issues.
      Now I've tried the same on my x86-64 Linux system but the installer (invoked from Firefox) just does nothing (visible) and calling it on the commandline fails like this:

      #> Adobe\ AIR\ Application\ Installer alcon.air
      sh: pactl: command not found
      unexpected error: ArgumentError: Error #2004
        • 1. Re: AIR application installer not working on Linux x86-64
          marclijour

          Same here. I had it working back in April and I use TweetDeck for a while. Now that I try to upgrade I get this error message, not a friendly one. 2004? What does that mean exactly? If only AIR told me what's wrong...  By the way, kudos to Adobe for this editor, that's the weirdest internet thing of the week! It is totally useless to type my text, I have to manually turn it off, and it does not work with my preferred browser (Konqueror). I guess the road is going to be long with AIR...

          • 2. Re: AIR application installer not working on Linux x86-64
            jbenson@oper8 Level 2

            I've come across this before and this blog post helped me solve it:

             

            http://tech.element77.com/2009/04/adobe-air-on-64-bit-linux-argumenterror.html

            Turns out that just running the installer ("Adobe AIR Application Installer") opens a GUI where one can select the .air file and then the installation goes through without problems. Perhaps the command line interface expects arguments in some undocumented syntax.

             

            Essentially I think the application installer needs an absolute path and just performing an install that way should fix your issue.  (By the way, this also works for other platforms (Windows / OSX) as well)

             

            I've yet to find out what to do to alter in your .air file (if possible) to overcome this issue automatically for users.

            • 3. Re: AIR application installer not working on Linux x86-64
              marclijour Level 1

              Hi Jason,  Thank you for the tip. Unfortunately it does not work here.   I get to the point where I can pick the file from the GUI (or I just add the file name on the command line), and from there I click install and I enter my root password. The 2004 error happens during the installation process (a progress bar runs twice with a label talking about installation).  At first, I got an error about canberra-gtk-module.so, which I solved by installing the 32 bit version of the libraries. # urpmi libcanberra-gtk To satisfy dependencies, the following packages are going to be installed:    Package                        Version      Release       Arch (medium "Main32")   libcanberra-gtk0               0.11         4mdv2009.1    i586   libcanberra0                   0.11         4mdv2009.1    i586   libvorbisfile3                 1.2.0        5mdv2009.1    i586  The installer does not complain about anything now when I run it from the command line, but it still sends an error 2004 in the GUI (nothing on the command line, and no more clue on the GUI about the file that may not be referenced by an absolute path, or whatever is missing).

              • 4. Re: AIR application installer not working on Linux x86-64
                marclijour Level 1

                (Note to the text editor: learn to respect a layout as well as plain text does!)

                • 5. Re: AIR application installer not working on Linux x86-64
                  jbenson@oper8 Level 2

                  Well that's as far as I can go with this, you have of course specified the full path to the file via Command Line (or GUI):

                   

                  Command Line example: (escaping spaces)
                  $ Adobe\ AIR\ Application\ Installer /your/full/path/airpackage.air

                   

                  I assume you've also tried to install with the air package in the same directory as the application installer.  (Really should not matter, although at this point worth trying).

                   

                  pactl:
                  I don't see how this could cause the error you're receiving but in your original post I see that you don't have pactl installed, you can of course, satisfy the dependency by installing pavucontrol (ie apt-get install pavucontrol on systems with apt).  I wasn't aware that AIR apps required pulse audio but it wouldn't be a surprise as lots of things do require it for audio output (python toolkit etc).

                   

                  The only thing left is to see if others can replicate and / or report as a bug.

                   

                  To report a bug for Adobe AIR goto:
                  https://www.adobe.com/cfusion/mmform/index.cfm?name=wishform

                   

                  If you want someone else to try and confirm just send me your air file here or a link in a private message.

                   

                  Good Luck!

                  • 6. Re: AIR application installer not working on Linux x86-64
                    marclijour Level 1

                    Thank you for your help, Jason. Yes, I tried all this different times. I have pavucontrol installed in the system (pavucontrol-0.9.8-1mdv2009.1.x86_64).   pactl 0.9.15 Compiled with libpulse 0.9.15 Linked with libpulse 0.9.15  Pulseaudio is standard on Mandriva Linux.  Try to install TweetDeck http://downloads.tweetdeck.com/TweetDeck_0_26.air (replacing version 0.25 on my system). Or try to install  Seesmic Desktop v0.4 from http://desktop.seesmic.com/ (click on black widget "installing application" and clicksave on the AIR pop up -it is a Flash component and I can't get the straight URL). Once the air file is on the desktop, try to install it.